Spyder Forums  

Go Back   Spyder Forums > Spyder Markers > Discontinued Markers
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-20-2006, 12:41 PM
johnnyblast's Avatar
johnnyblast johnnyblast is offline
Member
 
Join Date: Dec 2005
Posts: 173
Unhappy sweetspot trigger installation.

i think i didn't do the installation right... i took out the stock trigger and remove the spring because with sweetspot trigger the spring doesnt really help... so trigger is moving around and if i have my gun on, sometimes it fires. i dont really mind but... is it suppose to be like this???
Reply With Quote
  #2  
Old 01-20-2006, 01:04 PM
WhatThaSmurf's Avatar
WhatThaSmurf WhatThaSmurf is offline
I'm Back!
 
Join Date: Dec 2005
Location: Nashville, TN
Posts: 1,311
Default Re: sweetspot trigger installation.

it will wiggle left and right, its a little bit skinnier, but mine has never shot randomly...
__________________
My favorite DJ, and all his music is free from his site.
Pretty Lights

Three years is too long without paintball.
Reply With Quote
  #3  
Old 01-20-2006, 01:20 PM
shunut's Avatar
shunut shunut is offline

Respected, period.
 
Join Date: Dec 2005
Location: Gilbert, AZ
Posts: 5,359
Default Re: sweetspot trigger installation.

You must have a light switch in there, probably 50g is what I'm guessing. That use to happen on my esp frame all the time. Only thing you can really do is either find a spring to put in there to give a little bit of return or you can do the magnet mod, which is what I would recommend.
__________________
Viva La KUSA!

KUSA Feedback

2006 Non-Spyder of the Year - The Shunut Spimmy


Shunut Creations
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 07:09 AM.