Spyder Forums  

Go Back   Spyder Forums > General Spyder Discussion > Veteran Forum
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 04-12-2006, 04:13 PM
ShadowX's Avatar
ShadowX ShadowX is offline
ECLIPSE FTW
 
Join Date: Dec 2005
Location: Atlanta
Posts: 757
Default Well, I got my Evil Detonator....

I recently purchased an Evil Detonator Reg for my ION. All was well, I took it out of the packaging and installed it on my ION. I then turned the reg all the way down, and aired up my ION. It was at 0 PSI, as expected,.. I slowly turned it up to around 160 PSI. I then took my eyes off of the guage and shot a couple bursts. Felt nice. Then i looked back at the guage and fired a shot... It dropped to about 120 PSI and then proceeded to rise back up to 160 PSI, but it took a total of about 1-2 Min. to do so. Now, I know the Detonators have a HORRIBLE break in period and it takes about 2 cases of paint to fully get them settled in, but.. Is that 2 Min. period it takes it to, i guess, "recharge" back to the 160 PSI normal? I was just a little suspicious and wanted to know if anyone has heard of this happening or has expierenced this themselves.

Thank guys and Lmk anything you know...
__________________
http://www.spyder.tv/forums/showthread.php?t=158

^ ^ ^ ^ ^ TRUST ^ ^ ^ ^ ^ ( + 12, - 0 )

Blue Dynasty ION - HP PMI 68/45 - Smoke Vlocity
ULTIMATE PAINTBALL INC.

www.ultimatepaintballgeorgia.com
Reply With Quote
  #2  
Old 04-12-2006, 04:20 PM
Ares's Avatar
Ares Ares is offline
shake shake shake shake shake shake
 
Join Date: Dec 2005
Location: delaware
Posts: 496
Default Re: Well, I got my Evil Detonator....

recharge that slow is never normal to my knowledge. did you lube it?
__________________
i shoot mags
Reply With Quote
  #3  
Old 04-12-2006, 04:25 PM
ShadowX's Avatar
ShadowX ShadowX is offline
ECLIPSE FTW
 
Join Date: Dec 2005
Location: Atlanta
Posts: 757
Default Re: Well, I got my Evil Detonator....

No, I just screwed it into the VA and aired it up, I thought since it was brand new, It was lubed from the factory. What should I lube it with, Dow 33?
__________________
http://www.spyder.tv/forums/showthread.php?t=158

^ ^ ^ ^ ^ TRUST ^ ^ ^ ^ ^ ( + 12, - 0 )

Blue Dynasty ION - HP PMI 68/45 - Smoke Vlocity
ULTIMATE PAINTBALL INC.

www.ultimatepaintballgeorgia.com
Reply With Quote
  #4  
Old 04-12-2006, 04:35 PM
Ares's Avatar
Ares Ares is offline
shake shake shake shake shake shake
 
Join Date: Dec 2005
Location: delaware
Posts: 496
Default Re: Well, I got my Evil Detonator....

i would try dow 33, but im am unfamiliar with detonators. lets see if anyone knows something about this reg
__________________
i shoot mags
Reply With Quote
  #5  
Old 04-12-2006, 04:55 PM
durrell's Avatar
durrell durrell is offline
wat
 
Join Date: Dec 2005
Location: North Carolina
Posts: 3,927
Default Re: Well, I got my Evil Detonator....

No, it's not normal. Shocker I had once did that. I'd lube the reg and go from there.
__________________
lol paintball
Reply With Quote
  #6  
Old 04-12-2006, 08:56 PM
MetDTHero MetDTHero is offline
New Guy
 
Join Date: Mar 2006
Posts: 15
Default Re: Well, I got my Evil Detonator....

factories never lube anything to what they fully need to be....

always lube out of the package.
Reply With Quote
  #7  
Old 04-13-2006, 03:43 AM
ShadowX's Avatar
ShadowX ShadowX is offline
ECLIPSE FTW
 
Join Date: Dec 2005
Location: Atlanta
Posts: 757
Default Re: Well, I got my Evil Detonator....

Does anybody know how to disassemble the Detonator? Ill look around PBN I guess...
__________________
http://www.spyder.tv/forums/showthread.php?t=158

^ ^ ^ ^ ^ TRUST ^ ^ ^ ^ ^ ( + 12, - 0 )

Blue Dynasty ION - HP PMI 68/45 - Smoke Vlocity
ULTIMATE PAINTBALL INC.

www.ultimatepaintballgeorgia.com
Reply With Quote
  #8  
Old 04-13-2006, 03:48 AM
ShadowX's Avatar
ShadowX ShadowX is offline
ECLIPSE FTW
 
Join Date: Dec 2005
Location: Atlanta
Posts: 757
Default Re: Well, I got my Evil Detonator....

Well I found a PDF file that shows me how to do it, I'll let you guys know how it goes, Thanks.
__________________
http://www.spyder.tv/forums/showthread.php?t=158

^ ^ ^ ^ ^ TRUST ^ ^ ^ ^ ^ ( + 12, - 0 )

Blue Dynasty ION - HP PMI 68/45 - Smoke Vlocity
ULTIMATE PAINTBALL INC.

www.ultimatepaintballgeorgia.com
Reply With Quote
  #9  
Old 04-13-2006, 04:15 AM
*EM1-Master*'s Avatar
*EM1-Master* *EM1-Master* is offline
Finally! A special name!!
 
Join Date: Dec 2005
Posts: 561
Default Re: Well, I got my Evil Detonator....

Shoulda gone CP
__________________
That Kirby Guy
Reply With Quote
  #10  
Old 04-13-2006, 08:33 AM
Nader's Avatar
Nader Nader is offline
Do what you like.
 
Join Date: Dec 2005
Location: Whore Island, CO
Posts: 1,227
Default Re: Well, I got my Evil Detonator....

Heh yeah I had the same problem a little while ago with my shocker, it would start at 180psi, then drop to like 160, and take forever to get back up. You should buy it some viagra.
But seriously, I just lubed it up and replaced the seat, and eveythign worked fine, no problems at all with recharge rate.
__________________
Stay on the other side of the road
'Cause you can never tell
We've a thirst like a gang of devils
We're the boys of the county hell
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 10:36 AM.