Spyder Forums  

Go Back   Spyder Forums > General Spyder Discussion > General Spyder Forum
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 04-03-2006, 08:00 AM
Ariesah Ariesah is offline
Member
 
Join Date: Dec 2005
Posts: 32
Default Problem

Well I thought I was done working on my LP Tl+ when I noticed that my pressure seems to be climbing higher with each passing game. It use to be set at 350 psi @290fps and now it's 500psi @280fps. The only thing I changed was adding the DH striker, which I thought would help me lower my psi. Is it possible that the Regulator (BL Torp) needs to be rebuilt?? or could there be another reason for the pressure climbing?
Reply With Quote
  #2  
Old 04-03-2006, 11:32 AM
FullMetal FullMetal is offline
Electra Club Member #3
 
Join Date: Jan 2006
Location: Ms.but not by choice
Posts: 64
Default Re: Problem

Welcome to the world of Spyders.
__________________
2k1 STO Autococker
Reply With Quote
  #3  
Old 04-03-2006, 11:57 AM
Ariesah Ariesah is offline
Member
 
Join Date: Dec 2005
Posts: 32
Default Re: Problem

got to love em. Never-the-less they are easy to fix, just sometime a pain.
Reply With Quote
  #4  
Old 04-03-2006, 03:57 PM
thechubbss12's Avatar
thechubbss12 thechubbss12 is offline
Indian
 
Join Date: Dec 2005
Location: Moore, Oklahoma
Posts: 1,506
Default Re: Problem

Humm do the usual clean and check....

If so DH strikers are alot lighter meaning you will def need a lighter Valve spring... so your best bet is to buy a spring kit and change them around....
__________________
OKC Yayo

http://www.spyder.tv/forums/showthread.php?t=1831 <-FEEDBACK

Quote:
Originally Posted by vwjimmy
Props to thechubbss12......
the appraisal pimp!!!!
http://www.splatsavers.homestead.com/products.html <- buy these headbands!
Reply With Quote
  #5  
Old 04-03-2006, 04:16 PM
alk1979's Avatar
alk1979 alk1979 is offline
Noob
 
Join Date: Mar 2006
Location: Pennsylvania
Posts: 56
Default Re: Problem

From what you wrote I guess you aren't adjusting the regulator. Is it possible the guage is bad? Don't seem right you would gain psi but lose velocity.

I did catch my bl torpedo not regulate one time. I turned on the tank and the guage went right past 460 "where it should stop" and on up to 600+ "guage stops at 600".
__________________

Electra DX---Evlution II
BL torpedo
Phycobalistics long drop
Drilled and Bored VA
Stock Valve---Bolt mod
32* light valve heavy main
Polished internals 14" evil pipe kit
48/3000 pmi r/t switch mod
Stock for the rest
Reply With Quote
  #6  
Old 04-03-2006, 06:21 PM
ooglieboogliebob ooglieboogliebob is offline
Marine Corps.
 
Join Date: Dec 2005
Location: Pasadena, MD
Posts: 2,565
Default Re: Problem

... the gauge could be bad ... but i doubt it ... spring kit would be a possible solution .. and probably the best one for several reasons ...

most likely it's what chubbs said .. the lighter striker with the heavy valve ... and the light main .. won't let as much air in ... thus making you have to increase PSI's ...

Remember to clean and polish your gun though ... (internals)
Reply With Quote
  #7  
Old 04-04-2006, 05:29 AM
Ariesah Ariesah is offline
Member
 
Join Date: Dec 2005
Posts: 32
Default Re: Problem

OK to make it easy I post my current set up.
Spyder TL +
32* Spring Kit (Light Valve/Med. Main) <--- I think....
Spudnukl Bolt
DH Striker
NDZ HP Valve
Bob Long Torp
Macro Line

The Gauge is only a few months old, so I do ont know if that is what is causing the problem, however it could be. I know that last week I retested the spring combos and had a lower psi than I am acheiving now. Im thinking that I need to rebuild the torp, so what besides DOW33 can be used to lube the regulator?
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 12:22 AM.