Spyder Forums  

Go Back   Spyder Forums > Spyder Markers > Electronic Markers
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 05-01-2011, 06:25 PM
ChrisSoprych ChrisSoprych is offline
New Guy
 
Join Date: Apr 2011
Posts: 1
Default Possible battery problem

I have a 9.6v JAVA battery that's 6 years old. It is fully charged. I put in my 2005 Pilot and it will cycle 1 or 2 shots before giving me the battery light and switching on the safety. I take the battery out and replace it with a Spyder brand 9.6v and the gun shoots fine. I take the crappy JAVA battery and put into a 2004 Pilot and it gives me the same problem. Swap the battery back, problems are gone on that gun too.

What's going on? Were can I get a decent replacement battery?
Reply With Quote
  #2  
Old 05-02-2011, 04:55 AM
shunut's Avatar
shunut shunut is offline

Respected, period.
 
Join Date: Dec 2005
Location: Gilbert, AZ
Posts: 5,359
Default Re: Possible battery problem

Battery is probably shot, after 6 years I would say that it has lived its life.


New Battery
__________________
Viva La KUSA!

KUSA Feedback

2006 Non-Spyder of the Year - The Shunut Spimmy


Shunut Creations
Reply With Quote
  #3  
Old 05-02-2011, 06:43 PM
Talon's Avatar
Talon Talon is offline
dorito man
 
Join Date: Aug 2007
Location: Auburn NY
Posts: 152
Default Re: Possible battery problem

I would say so, most rechargeable batteries are only good for 3 years or 500-800 charges.
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 10:29 PM.