Spyder Forums  

Go Back   Spyder Forums > General Spyder Discussion > General Spyder Forum
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Thread Tools Display Modes
Old 05-02-2007, 12:46 PM
Spyder Addict
Join Date: Jan 2006
Posts: 1,008
Default Re: Rocket Valve Problem

have you removed the brass filter found in the stock asa?

if thats what you're using...

Your not changing the spring on the valve itself are you?
05 Pilot ACS - SPPS Dragon tail trigger, 50 gram switch, CCM feedneck, ACP Bolt, Sticky 3's, Trinity -7 deg. V/A, Rocket Valve, DH Titanium Striker, BL Torp., T board w/ Eyes, Cp Direct Mount On/Off, 275 fps@250 psi


Black to Olive PM6

"All men have fear. The brave ones lay it down and go forward...some unto death but all to victory!" - Kings Guard of Ancient Greece

My Feedback
Reply With Quote
Old 05-02-2007, 01:04 PM
VagabondStarJXF's Avatar
VagabondStarJXF VagabondStarJXF is offline
Join Date: Mar 2007
Location: Carshalton, Surrey, UK
Posts: 121
Default Re: Rocket Valve Problem

I'm not using the stock ASA and I haven't thought about changing the spring on the Rocket valve. I don't have one that'd fit it. I really can't think of anything else that I've not tried yet. There's only 2 things I can definitely say I haven't done and they are...

Get a rebuild kit
Try a completely new Rocket valve
***Rodeo Owners Club***

Feedback: PBN (+11/-0) SEA (+7/-0) SOC (+1/-0)
Originally posted by cali141
"Vagabond, i think youre alexander the great. Only reborn. And evil."
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -8. The time now is 06:16 PM.