Spyder Forums  

Go Back   Spyder Forums > Spyder Markers > Mechanical Markers
FAQ Members List Calendar Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
  #1  
Old 01-17-2011, 09:47 AM
CarbineKid CarbineKid is offline
Member
 
Join Date: Sep 2006
Posts: 33
Default Fixed thanks

I recently brought a NIB Spyder Xtra09, and I need some help solving a leaking problem. I cock the gun and then I screw in my Co2 tank. When the tanks screwed in. the gun leaks at the asa. Actually there a small hole on the bottom and thats where its leaking from...all the time. I know the holes a pressure release point for the tank...but this isn't right. It should be leaking there all the time...right??? So whats causing this...and how do I fix it?? Edited due to my own stupidity. Guns fine tank O-ring issue
Thanks

Last edited by CarbineKid : 06-11-2011 at 11:10 AM.
Reply With Quote
  #2  
Old 01-17-2011, 10:58 AM
Arias's Avatar
Arias Arias is offline
Member
 
Join Date: Nov 2010
Location: Puerto Rico
Posts: 65
Default Re: I need help fixing my New 2009 Xtra

Have you checked the tanks o ring. Also take a look at the threads both on the ASA and on the tank. Make sure to screw in the tank with enough force to where the valve is seated at the back rear end of the ASA. If all fails contact Kingman and have your marker serviced. They have excellent customer service.
Reply With Quote
  #3  
Old 01-17-2011, 01:17 PM
TheDarkShadow's Avatar
TheDarkShadow TheDarkShadow is offline
add 1,794 posts
 
Join Date: Feb 2008
Location: South East IN
Posts: 2,775
Default Re: I need help fixing my New 2009 Xtra

basically
a)something is stopping it fron screwing in all the way (possibly bad threading as stated above)
or
b)you have a bad o-ring or something is allowing the air to pass through where the asa and the tank meet
__________________
E-framed Sonix Pro
2009/2010 bone stock sonix
Reply With Quote
  #4  
Old 01-17-2011, 01:51 PM
CarbineKid CarbineKid is offline
Member
 
Join Date: Sep 2006
Posts: 33
Default Re: I need help fixing my New 2009 Xtra

Darn it, now I feel stupid. I checked the O-ring earlier, but upon checking again I noticed a hair line crack/tear. I swapped out the ring and its fine now...thanks
Reply With Quote
  #5  
Old 01-17-2011, 05:05 PM
Arias's Avatar
Arias Arias is offline
Member
 
Join Date: Nov 2010
Location: Puerto Rico
Posts: 65
Thumbs up Re: I need help fixing my New 2009 Xtra

Quote:
Originally Posted by CarbineKid View Post
Darn it, now I feel stupid. I checked the O-ring earlier, but upon checking again I noticed a hair line crack/tear. I swapped out the ring and its fine now...thanks
No problem were all here to help each other!
Reply With Quote
Reply


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 08:52 PM.