Spyder Forums  

Go Back   Spyder Forums > Spyder Markers > Mechanical Markers
FAQ Members List Calendar Search Today's Posts Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-11-2009, 04:51 AM
Kingfisher Kingfisher is offline
New Guy
 
Join Date: Jan 2009
Posts: 11
Default E-MR1 chops (bad) - covering my bases

Guys, my E-MR1 chops something awful and I want to make sure that I've got all of my bases covered to try to alleviate the problem. This is a relatively new marker and it chops in single-shot, burst or full-auto modes. Doesn't matter. I know the hopper is problem #1 so I've got a Ricochet AK on order, which should make it better as I've tried someone elses on the gun and it feeds noticeably better, but it still runs out of ammo and or chops even in single shot mode. I've tried numerous brands of paint, all perform relatively the same in terms of chops. I'm also about to order an all metal feedneck for it, like a Trinity or Maddog. Seems like the plastic elbow has too many steps molded in it which is causing some the trouble as well.

Last but not least, I'm running C02 on a remote.

Anything else I need to knock out while I'm at it? I've got a big scenario game coming up this weekend and I'd like to get through more than one hopper without multiple chops.

Sorry for the convoluted post, it's too early on a Monday.
Reply With Quote
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -8. The time now is 03:44 PM.