Thread: Not firing
View Single Post
Old 06-16-2012, 11:50 AM
Mikesgame Mikesgame is offline
New Guy
Join Date: Feb 2012
Posts: 3
Default Re: Not firing

Originally Posted by Talon View Post
try a new battery
The battery I tried was about a week old. I had just put it into the gun, so I dont think it should of run low. Plus the battery light on the gun said the battery was fine.

Originally Posted by shunut View Post
First of all, Welcome to the Forum.

When you put it all back together did you lubricate everything? If the o-rings are dry it could cause that problem.

Is your Electra stock? Everything after this is based on the assumption that the Electra is stock.

When you screw your tank in, do you screw it in all the way? Once the tank is on and you screw in the On/Off, do you screw that in as far as you can?

Your marker has a regulator, have you tried adjusting that? From your description, I would recommend turning up the pressure. The regulator may need to be serviced as well. Which would require you to take it apart, clean and relube everything.

For help with adjusting the pressure or taking apart the regulator to service it, use the manual for your marker, found here
I took it apart and lubricated it all about a month ago. I'm sure I screwed the tank in all the way, and I had actually bought a new on/off screw about a year ago b/c I lost the origanal. So I don't think either of those is the problem?

I'm guessing the regulator is the thing you screw the tank too? Would you need to open it up an clean it? How does that work? And how would you adjust it?

Edit: Sorry I feel stupid. I read the manual and did what it told me. I'll go out tomorrow morning and test it out.

Last edited by Mikesgame : 06-16-2012 at 09:47 PM.
Reply With Quote