Spyder Forums

Spyder Forums (http://www.spyder.tv/forums/index.php)
-   Electronic Markers (http://www.spyder.tv/forums/forumdisplay.php?f=92)
-   -   valve leaking?! (http://www.spyder.tv/forums/showthread.php?t=21885)

junits15 06-29-2011 09:20 AM

valve leaking?!
 
So my gun ('09 pilot) has a slow leak from the valve. The problem seems to be the cupseal, I swapped it out for the 2nd one I have but that one leaks too. I tried unscrewing the valve pin a bit from the cupseal and it stopped the leak for a while but it came back. I think the hammer hitting it screwed it back in but that's a stretch. Its very strange it comes and goes randomly, the only other thing I think it might be is the valve spring. Can they become over-compressed after a while and not push hard enough on the valve?

ALSO i removed and carefully inspected the valve body but it seemed perfect and had no dings or scratches in it.

Lawpass 06-29-2011 10:29 AM

Re: valve leaking?!
 
Are you sure its the cupseal and not the valve o-ring thats leaking? You might try putting some oil in there and see if it does anything.

junits15 06-29-2011 12:20 PM

Re: valve leaking?!
 
Quote:

Originally Posted by Lawpass (Post 258479)
Are you sure its the cupseal and not the valve o-ring thats leaking? You might try putting some oil in there and see if it does anything.

I'm sure, because the valve o-rings were perfect and I re-oiled them before I but the valve back in, also when I messed with the cupseal the leak stopped for a bit and came back. This happened once before and I just swapped the cupseal and it stopped but now its back

Lawpass 06-29-2011 12:42 PM

Re: valve leaking?!
 
Make sure you cock the marker before airing it up.
It seems unlikely that its valve spring is worn out, but I guess its possible. By any chance did you look at the face of the valve while you had it out?

junits15 06-29-2011 01:46 PM

Re: valve leaking?!
 
Quote:

Originally Posted by Lawpass (Post 258481)
Make sure you cock the marker before airing it up.
It seems unlikely that its valve spring is worn out, but I guess its possible. By any chance did you look at the face of the valve while you had it out?

yes I looked at the rim that the cupseal contacts with it is 100% perfect no scratches nicks or anything wrong with it. Its odd because I unscrewed the valve pin from the cupseal about 1cm and the leak stopped but as soon as I shot it it came back. Its a very slow leak, and can only be heard if you put your ear to the feedneck. Also I am cocking it when I air it up. I'm low on air but it does this no matter how much is left in the tank.

Lawpass 06-30-2011 06:34 PM

Re: valve leaking?!
 
Wow strange! Is your velocity where it should be? I guess trying a replacement spring is a cheap fix if you have a spring kit handy. You can cut down a spare mainspring if you had one of those instead.

junits15 07-01-2011 12:42 PM

Re: valve leaking?!
 
Quote:

Originally Posted by Lawpass (Post 258495)
Wow strange! Is your velocity where it should be? I guess trying a replacement spring is a cheap fix if you have a spring kit handy. You can cut down a spare mainspring if you had one of those instead.

Im going to have to try that, I don't have any extra springs so I might try a spring kit. The velcity adjuster is all the way out does that make a difference?


All times are GMT -8. The time now is 06:41 AM.