Spyder Forums

Spyder Forums (http://www.spyder.tv/forums/index.php)
-   Veteran Forum (http://www.spyder.tv/forums/forumdisplay.php?f=3)
-   -   I Need Solutions Fast For 2 VS2's (http://www.spyder.tv/forums/showthread.php?t=21657)

fatkidfrompbaz 01-20-2011 02:49 PM

I Need Solutions Fast For 2 VS2's
 
I need solutions before this Saturday.

1. First off my VS has a small leak near the valve. I double checked the O-rings and the cup seal and even swapped the seal cups and keeps leaking. So could it be?

2. My friends VS pressure does not go past 100psi. I keep turning up the pressure but the needle does not move. Everything is lubed and has been checked.

I need this solved ASAP because I have a 3 man tournament this Saturday.

Arias 01-20-2011 08:47 PM

Re: I Need Solutions Fast For 2 VS2's
 
I would recommend removing the trigger frame and then remove the striker and change the orings (remember to lube them), even though may may look fine they might have a small tear or crease. Then push the striker back into the marker and finally attach the trigger frame. Do this in the exact same order as listed to prevent the sear from cutting the strikers oring.

shunut 01-21-2011 03:50 AM

Re: I Need Solutions Fast For 2 VS2's
 
It says you double checked the orings, but even the smallest imperfection that you can't see, can cause a leak. I'd change the orings.

As far as your friend's pressure not going past 100psi, is the marker still operable? It is possible the gauge is broken.

If you haven't figured this out, I could give you my address, you could come to my house and I could look at them. Let me know, I'm free today after about noon. I have tons of orings and extra parts.

fatkidfrompbaz 01-21-2011 07:33 PM

Re: I Need Solutions Fast For 2 VS2's
 
Update: I fixed my friends reg problem and it works perfectly after seeing a thread on PBN. Now it recocks and shoots As for mine, I changed all the o-rings and lubed them up and the leaked disappeared. Thank you shunut for the tip and thank you Arias for helping me.

shunut 01-21-2011 07:39 PM

Re: I Need Solutions Fast For 2 VS2's
 
Anytime you need help fast let me know, I'm not far from you.

fatkidfrompbaz 01-23-2011 03:11 PM

Re: I Need Solutions Fast For 2 VS2's
 
Quote:

Originally Posted by shunut (Post 256095)
Anytime you need help fast let me know, I'm not far from you.

Thanks shu.

fatkidfrompbaz 07-25-2011 07:22 PM

Re: I Need Solutions Fast For 2 VS2's
 
Ok, its been months since i have posted this, but it seems my VS2 has the same problem. I have checked all the O-rings and cup seal and they are all fine. Now there is also a small leak on the hole that holds the valve screw in, even if I add teflon. So what the **** is going on?

Edit: Solution found, apparently I was tightening the screw to much which, in my theory, lifts the valve up and air goes under..


All times are GMT -8. The time now is 11:33 PM.