Spyder Forums

Spyder Forums (http://www.spyder.tv/forums/index.php)
-   Electronic Markers (http://www.spyder.tv/forums/forumdisplay.php?f=92)
-   -   Electra Fails again! (http://www.spyder.tv/forums/showthread.php?t=19458)

Drummie224 02-28-2009 03:03 PM

Electra Fails again!
 
Ok, it doesnt turn on now. I have the 05 acs electra with rocking trigger frame. One day it decided to die. I talked to my pb shop and they said it was either the board or the on/off switch. Im posotive its not the board. Any ideas?

ferret15 02-28-2009 03:11 PM

Re: Electra Fails again!
 
unless your battery is 100% discharged then it sounds like the board,

if your battery is completely dead and for some reason its not charging you can stick a 9v in just to see if the board turns on.

otherwise. something is wrong with the board.

oldironmudder 02-28-2009 03:43 PM

Re: Electra Fails again!
 
Take a brand new 9 volt battery & replace it with the one in the frame. Turn on the frame. If it powers up, it was the battery, if not, look for loose or broken wires. Tell us what you find or what happens.

Drummie224 02-28-2009 06:11 PM

Re: Electra Fails again!
 
I already tried that.
9v=nothing.
I charged the battery for 30 hours....nothing. maybe there was a static charged the just shorted the board. I dont know.

oldironmudder 02-28-2009 08:27 PM

Re: Electra Fails again!
 
30 hours, is WAY to long. I want to say 8-14 hours is all that is needed for the 9.6v rechargeables.

Have you looked at the wiring?



Before you spend money at your local shop (kinda feel bad about saying do use your locals) call kingman (1-800-kingman) & talk with someone in the tech. department (ext. 126). You may have to send it in for warrenty work which should only cost shipping to them.

Dinmiller 03-03-2009 06:26 AM

Re: Electra Fails again!
 
According to spyder the longest the 9.6v battery should be charged is 8 hours. No more, it can cause problems.


All times are GMT -8. The time now is 07:25 AM.