PDA

View Full Version : Leaking Regulator


RailDemon
02-13-2007, 06:47 AM
Hi, one of my friends bought a Rodeo a while back and havent had any problems with it until now, there is air leaking from the regulator, on the regulator thw top bit is silver and the bottom bit is black, its leaking in etween the slver bit and the black bit right next to a tiny hole, what could the problem be?

vwjimmy
02-13-2007, 07:40 AM
Sounds like there's a bad o ring inside the reg.....
Did you adjust it any lately? Have you tried to?
It might need to come apart and be resealed, and adjusting it might help it. Sometimes just moving the piston by adjusting them can help them seal up. I would try that first. Then, if it still leaks, it is time to take it apart and reseal it.
Hope this helps and welcome to the forums!

RailDemon
02-13-2007, 08:27 AM
Yer i tried to take the regulator apart but it doesnt theres nothin in the manual that tells u how to take apart the regulator and i dont wanna mess around with it incase i damage the gun because i use a Proto Matrix Rail which is an autococker and ive only ever owned one other gun which was a Pilot lol, if u could tell me how to strip the regulator then i will be grateful, thankyou.

Hossy
02-13-2007, 08:29 AM
Yer i tried to take the regulator apart but it doesnt theres nothin in the manual that tells u how to take apart the regulator and i dont wanna mess around with it incase i damage the gun because i use a Proto Matrix Rail which is an autococker and ive only ever owned one other gun which was a Pilot lol, if u could tell me how to strip the regulator then i will be grateful, thankyou.
i think it screws right out bud
follow the manual
a Proto Matrix rail isnt a cocker.....

RailDemon
02-13-2007, 11:21 PM
I dont mean an autococker as in a WGP Autococker, but the Rail has an autococking system as you do not have to pull the bolt back for the gun to shoot.

ooglieboogliebob
02-14-2007, 04:42 PM
Hmm ... If it's leaking between the two parts my guess is that the SS line is leaking. Unscrew the Steel Braided Hose on the regulator side, then try putting teflon tape on it and screw it in. If that doesn't work, then we'll go on from there.

RailDemon
02-15-2007, 01:17 AM
Yer ive tried that before because at first i wasnt sure where the leak was coming from so i wrapped teflon tape round the threading of the hose but its still leaking

splater18
02-23-2007, 02:18 PM
I dont mean an autococker as in a WGP Autococker, but the Rail has an autococking system as you do not have to pull the bolt back for the gun to shoot.

I think they call it a closed bolt marker but don't quote me on this

druid
02-23-2007, 03:05 PM
howz "spool valve" sound to you guys? :D

Anyway...the reg's probably needing a good cleaning and greasing. Dow 33 for Regulator seats and seals

thelastdefence
03-13-2007, 04:06 AM
i am having the same problem with my rodeo, i switched o-rings and it worked, and then it happened again and i greased and re-0-ringed, but it didnt work the second time.