PDA

View Full Version : what the?


ross * pilot
12-27-2006, 04:20 PM
I have a question with my 12v. revvy. I put in brand new batteries, right of the box, and put them in. I use two 9 volt batteries to power it, and i shot like 100 shots, and ALREADY the battery light, signaling to change, turns on. Any ideas?

PumaPride04
12-27-2006, 07:42 PM
get alot of batteries

twiztidjuggalo
12-27-2006, 08:17 PM
it happens sometimes, u do occasionally get bad batteries right out of the box, just get some more and try again, if ur problem continues thn something might be wrong.. i use a 9.6volt battery in my loader and gun nd it seems to preform much better then with just a regular 9volt, so maybe u should give that a try, and most come rechargeable so there for ur saving urself money in the long run

druid
12-27-2006, 08:57 PM
yeah, especially if they are cheap batteries.

Get 4 rechargables and charger for your car. Keep 2 charged and ready at all times while using the other 2. Stores link in my sig for Megabatteries

ross * pilot
12-28-2006, 11:59 AM
They are duracell so i dont think that they are the cheapest.. but who knows. Yeah, ill try using 9.6 volt next time. But i shot it today, and it was working flawlessly, lol. Maybe it was just a fluke or something. thanks for the help

Halucin8
12-28-2006, 01:15 PM
my egg was doing the same thing until i found a wire pinched to one of the screws holding it together and giving me a short to ground killing my batteries. atleast that is what i assume caused it cause once i fixed the wire and made sure it was clear it hasnt' done again and it has been months

ross * pilot
12-29-2006, 03:09 PM
Ok, ill look for that.