PDA

View Full Version : Loc-tite not "loc"ing?


Hob Hayward
11-03-2006, 03:37 PM
My bro got a new feedneck for his mongoose and it being a threaded feedneck, he got some red loc tite to hold it on, however, it doesn't dry, it just stays as a liquid, even when left for more than a day. Anyone know whats wrong?

Drefish99
11-03-2006, 04:17 PM
Shake up the bottle. Make sure the threads are clean of anything. Oil or old paint can make it not work well. If I were you I would even clean off the area well and then reapply then let it cure overnight. Make sure to shake up the bottle.

DRAGON
11-03-2006, 04:18 PM
He forgot to shake the bottle before applying it or he did not clean the threads with alcohol to remove any oils that can mix with the Loctite and make it so it doesn't dry -

EDIT: Dang you Dre! Great minds think alike - :smirk:

claustrophobia9
11-03-2006, 04:47 PM
red loctite requires heat for removal. dont apply it to a feedneck...

you can screw in after the loctite drys and still get a good effect.

Nenkitsune
11-03-2006, 06:09 PM
Use blue loctite. it still hardens and makes it so it won't get loose, but you can get it off much more easily than red loctite

Eaglelox
11-04-2006, 05:04 AM
locktite is anaerobic. so it wont harden if it has air on it. after cleaning well, use only a little on the threads.

Hob Hayward
11-04-2006, 06:35 AM
Hmm, well he uswed alot, and he didn't clean it very well to my knowledge so I'll pass that along. And there was red loc-tite on the old feedneck, so thats what he got. Besides, the store didn't have blue...

Thanks all.

Gunny462
11-05-2006, 11:30 AM
Because the original color was red does not mean it was true locite but could have been another brand. Also make sure that the outside temp is correct or it won't 'dry' either.