PDA

View Full Version : Help me out, I'm confused


Total90Oliver
10-20-2006, 09:17 AM
Alright, so I decided to air up my Imagine and take some shots because I was bored, so I screw in the tank, and as soon as it is in all the way, it starts to leak, magor leakage. It sounds like its coming from the ASA and the Whole Hose, Expansion chamber, and ASA are really cold after.

Please Help me out please

shunut
10-20-2006, 09:18 AM
Check the oring on your tank.

Take the fitting off and wrap it with some teflon tape.

bamf-hacker
10-20-2006, 09:19 AM
check your tank o-ring...

Total90Oliver
10-20-2006, 09:30 AM
alright I just tested it and this is what happened, I screw in the tank and it started leaking through the end of the hose where the expansion chamber is, so Im wondering what the hell could it be, so I take off the expansion chamber and the hse is loose, but when I screw in the expansion chamber the hose loosens off, so Now i am really confused, as I screw in the Exp. Chamber the hose unscrews, as I tighten the hose the expansion chamber is out.

Total90Oliver
10-20-2006, 09:31 AM
And how do you take the O-ring off of your tank

08Lud08
10-20-2006, 10:11 AM
take off the expansion chamber and tighten the hose and the screw the expansion chamber on and then screw the asa down.

Total90Oliver
10-20-2006, 10:19 AM
how do you take o-rings off, just tell me that

vwjimmy
10-20-2006, 10:27 AM
the o ring on the end of the tank???
a small tip under it or just try to strech it so you can grab it and pull it off....

pb34
10-20-2006, 12:13 PM
I had this exact problem with my pilot. It turns out that i was missing one of the screws that holds the drop foward to the trigger frame. Every time i put pressure on the tank the drop foward moved causing the hose to move and loosening the screw. So you might want to check to make sure you have all the screws.