PDA

View Full Version : problems with electric board on electra 05


paintballluver93
07-27-2006, 10:24 AM
I want to know why my electra will set it self on 6 burst,3 burst, and auto. but when i pull and release the trigger it goes right back to the semi mode and i have to set it again.Is this normal??????????(i just bought this electra from a friend, i dont know much about it.)

Command2A
07-27-2006, 11:33 AM
I want to know why my electra will set it self on 6 burst,3 burst, and auto. but when i pull and release the trigger it goes right back to the semi mode and i have to set it again.Is this normal??????????(i just bought this electra from a friend, i dont know much about it.)

Check the "Tournament" jumper, sounds like its been set to on.

paintballluver93
07-27-2006, 03:03 PM
i've already tried it-post any more answers if you can-thanks

SharpObjects
07-27-2006, 03:13 PM
Low battery maybe? Thats all I can think of.

paintballluver93
07-27-2006, 05:09 PM
Low battery maybe? Thats all I can think of.


No, i dont think thats what it is. i keep it charged when im not using it-thanks though

BloodLustAC
08-05-2006, 05:22 PM
It's gotta be low battery, or the more extreme answer - you killed your JAVA battery. Overcharging will kill the battery and prevent the gun from shooting fast, working in different modes, etc. You need a new one in that case... does the battery light come up at all?

applesauce
08-15-2006, 04:00 AM
there is a little red deal inside the handle that works itself free/loose....give it a good push back in, i had the same problem...

Command2A
08-15-2006, 04:38 PM
I want to know why my electra will set it self on 6 burst,3 burst, and auto. but when i pull and release the trigger it goes right back to the semi mode and i have to set it again.Is this normal??????????(i just bought this electra from a friend, i dont know much about it.)

Did you ever solve this problem?

paintballluver93
09-07-2006, 07:03 PM
yes i did, apple sauce was right! thanks alot