PDA

View Full Version : Imagine help and advice


Zirar
07-19-2006, 11:53 AM
Hey -

I just bought a remanufactured imagine from Action Village, and it isn't really working right. I charged the battery for 14 hours, and refilled my CO2 tank, but whenever I shoot it, the ball only goes about 20 feet. I tried adjusting the velocity, but it didn't do anything. Anyone have any ideas on why it isn't working? Or would it just be best to just return it to Action Village?

The other part of my question: Is it possible to take the electronic trigger off the imagine, and put it on my TL-R? If it is, would that be worth doing? Or is the imagine a better marker than the TL-R anyways?

Any advice would be very much appreciated!

Thanks,
~Zirar

Total90Oliver
07-19-2006, 08:10 PM
well u may have overcharged the battery i say get a new one charging for that battery should be only fom 5-8 hours a few more like 9 or 10 may be ok but 14. No Way!! Get the new battery and if it still doesnt work try and send it back to kingman or actionvillage or w/e. And yes you can but the imagine trigger frame on the tl-r

bamf-hacker
07-19-2006, 08:18 PM
The default charging time for the Imagine is 14 hours, but the battery may not be new.

Did you take the whole gun apart to inspect and lube everything? If not I would start there to make sure your springs are all good and all the parts are clean and together right.

ooglieboogliebob
07-20-2006, 03:06 PM
it's deffinetely not the battery since it did shoot 3 feet ... the battery just moves the sear which releases the striker ... it doesn't really have anything to do with how far your gun goes

I'd say you have missing parts, or put them in a wrong order ... Look at the manual and see if it's all right.

Make sure nothings in the air paths to block them, causing it not to shoot ...

GFXAddict
07-22-2006, 08:03 PM
Jeez I bought i refurbished imagine and im taking it out tommorow I hope I dont have any problems

DRAGON
07-22-2006, 08:54 PM
Sounds like you have the buffer in front of the striker not in back of it where it should be -

Hob Hayward
07-23-2006, 07:31 AM
That doesn't explain it not firing far though, if the buffer were in front it wouldn't fire at all... Are you sure the bolts in right side up...?

ooglieboogliebob
07-23-2006, 12:55 PM
... actually if the buffer was in front the striker would only have a limited space to compress the valve pin ... leading to less air getting to the bolt. That means it won't shoot that far ...

As i said check the manual for missing parts or if parts are in the order ... Easiest and Quickest way to find out is to do it for yourself. It'll give you a bit of learning experience also.

henchman
07-28-2006, 04:22 PM
Jeez I bought i refurbished imagine and im taking it out tommorow I hope I dont have any problems

I bought 3 refurbished Imagine's for myself and some friends, and all have performed flawlessly.

splater18
08-06-2006, 03:39 PM
mine just got here today works great

WhatThaSmurf
08-06-2006, 04:10 PM
Listen to Bamf, ooglie, and Drago; they know what they are talking about. But I am just wondering, why are people saying that they bought one? It doesn't really help with the problem. Maybe I'm just cranky from not going to sleep last night.

Eaglelox
08-07-2006, 06:47 AM
check the ball to barrel fit if none of the above helped.