PDA

View Full Version : primal velocity air problems


primal4
05-31-2006, 12:57 PM
well i just got my new raven primal and my first time out with it it suddenly wouldnt shoot up to its normal velocity. i tried adjusting the lpr, then the verticle regulator and neither helped. the most it goes is probly like 20fps. so, i put the lpr up and shot a paintball, cranked up the pressure, shot a paintball, cranked up the pressure, and it was going a little faster and then gun was louder. I tried the same with the verticle regulator but nothing changed the velocity stayed the same and the gun was just as loud. i took the gun apart, put it back together, same results. im stumped. im not sure if its a defect regulator or what. please give some help. thanks

SparkyGT
05-31-2006, 02:36 PM
check to see if your bolt is in upside down, 20 fps ? is probly what a mech gun would shoot a ball without c02

thechubbss12
05-31-2006, 04:21 PM
OK set the Preasure on your LPR to 125 PSI and 300 PSI on your vert regulator.....

I would tell you to return your primal but since you messed with your LPR preasure you voided your warrenty...... Becasue they come stock set at 100 psi (which is crap and would take like 400 PSI in your HPR to achive the 300 FPS mark....)

primal4
06-01-2006, 11:40 AM
bolt is right side up.... yeah i shouldnt have messed with the lpr.... i emailed kingman but anyone else know what could be wrong?

thechubbss12
06-01-2006, 12:28 PM
Take the entire gun apart.... Trigger frame, V/A and reg, Feedneck, all internals, eyes and covers .... Dont take the noid off but disconnect it from the board....

Now check the valve and see if it is upside down?..... if it is then put it were the Larger hole is facing the bolt.... Check all orings on the Ram, Ram sleeve, valve, valve pin.... now it could be that the orings on the ram has rolled... or that they are torn and there is barley any preasure being put on the valve from the ram...

Post back if any of this helps.

primal4
06-01-2006, 03:31 PM
took gun apart..... i looked and theres a tiny, little dent on the oring that stopps air between the ram and ram sleeve..... unfortunatly i dont have that size oring so im going tommorow to go get one... hopefully this works. ill post tommorow. thanks.

thechubbss12
06-02-2006, 03:27 AM
No problem.... the stock orings kingman puts on the primal.... Well too say the least BLOW....

primal4
06-02-2006, 11:16 AM
thanks a lot. i put on the new oring and now my gun works fine..... but its pretty loud. other than that though it works fine and im impressed with it. thanks for the advice.

thechubbss12
06-04-2006, 06:37 PM
Rock on man glad to be of assitance.