PDA

View Full Version : cupseal not sealing


Halucin8
05-30-2006, 03:21 PM
ok I may have screwed up buying the magnaport valve from 32 degrees. The marker works fine but i am leaking out the barrel. Like the cupseal isn't sealing. I even tried to put my original one in it and still no luck. Is it posssible that it won't seal because it is designed to run at lower pressures than the stock valve and since i have no reg yet that it is leaking until i lower my pressures???

ooglieboogliebob
05-30-2006, 03:31 PM
try a harder valve spring ... maybe you have the valve in backwards ....

Halucin8
05-30-2006, 03:37 PM
large hole towards the lpc correct? I even changed the orings out.

big_daddy_d
05-30-2006, 07:09 PM
order some lapco cupseals from countrypaintball, it'll clear the problem right up with the higher flowing valve the spyder seals don't do too hot of a job in making a good seal...

DRAGON
05-30-2006, 08:56 PM
Sounds like you're trying to use the brass cup seal that came with the valve. File it under 'G' for garbage. Try a stock cup seal and if that doesn't work go for the Lapco or Black Magic cup seals, They will work for sure. You did leave the cup seal guide in correct? -

Halucin8
05-31-2006, 11:57 AM
Yup l;eft the guide in and tried both the brass and my original cupseal. guess i will order some cupseals to keep around. thanx

viseversa2303
05-31-2006, 07:37 PM
Is that a good cup seal for my 05 Pilot ACS because it says for pump guns would if fit on mine. Thanks

http://www.paintballgi.com/index.asp?PageAction=VIEWPROD&ProdID=696

DRAGON
05-31-2006, 10:03 PM
Get the Lapco from Mike at County (http://www.countysports.com/shop/product.php?productid=1682&cat=268&page=2). Great guy and they're less there than the Black Magic at GI -

Halucin8
06-01-2006, 03:55 PM
alright now. i took my valve and cupseal in to work and lapped them both flat with 5 micron lapping compound. reinstalled and no leak. still gonna get some lapco ones just in case. i wonder if the whole problem wasn't the machineing on the valve to cupseal surface wasn't flat. and that is why everyone seems to have a problem getting them to seal

RushinPaint
06-01-2006, 05:51 PM
grats man, everytime something bad happens u learn something new. or some stuff like that