PDA

View Full Version : My 2 Spyder Complaints/Questions


Slammed0
04-30-2006, 04:41 PM
Ok, so far my Spyder Pilot ACS has treated me good. However, the back of the gun bugs me. Why? I have 2 reasons.

1. The cover in the back to protect the bolt just snapped off today. Anybody know where I can order a new one? Green arrow indicates.

Sorry the pictures kinda suck. Just took them quick.
http://i3.photobucket.com/albums/y57/Slammed0/RearEXACS.jpg

2. The adjusting thumb adjuster in the back never stays put. I get it just where I want it and then the more I shoot, the more that thing spins around eventually. And the screw is round at the end so you can't tighten it with an allen wrench or anything. I have looked back there and seen my screw almost screwed out of the adjuster during games. Silver arrow indicates. Does this happen to anybody else? Is there an aftermarket option? Any direction? Thanks!

http://i3.photobucket.com/albums/y57/Slammed0/RearEXACS2.jpg

redlantern
04-30-2006, 05:07 PM
The part that sits behind the bolt isn't really needed. It's there, more than likely, to keep crud out of the gun.

pman15
04-30-2006, 05:44 PM
for your velocity adjuster make sure screw is in 2 hold it in place at all times!{it would be a good idea}i was worried that my screw would come out again so i tightened it really hard so the screw doesn't even move{but i can still take the screw off thank god}

Slammed0
04-30-2006, 06:00 PM
for your velocity adjuster make sure screw is in 2 hold it in place at all times!{it would be a good idea}i was worried that my screw would come out again so i tightened it really hard so the screw doesn't even move{but i can still take the screw off thank god}

What did you use? The end of my screw is round so nothing fits in there. I thought maybe they would use a allen wrench type fitting.

Hob Hayward
04-30-2006, 06:37 PM
They do, does yours not have the little black set screw? Or is it just messed up?

Slammed0
04-30-2006, 06:43 PM
They do, does yours not have the little black set screw? Or is it just messed up?

No mine is just a little silver screw and there its just round at the end. Nothing of a common tool. :shrug:

Ares
04-30-2006, 06:44 PM
the set screw is probably in backwards. check the other side for an allen wrench hole

Slammed0
04-30-2006, 06:52 PM
the set screw is probably in backwards. check the other side for an allen wrench hole

:lol: you know I was JUST thinking that about 2 seconds ago.

Sandman_Bravo
04-30-2006, 07:16 PM
http://www.spyder.tv/forums/showthread.php?t=2460

druid
04-30-2006, 08:02 PM
heehee...looks like I made an impression. Good call sandman :D

pman15
05-01-2006, 03:50 PM
i use a allen wrench

Slammed0
05-01-2006, 05:22 PM
Ok guys. I got the tightening of the screw in the back. It was in backwards. Stupid me!! :lol: Thanks!