PDA

View Full Version : New 05' Imagine LED Spuddering


CBRuLater
04-16-2006, 04:44 PM
I just purchased a new 05' Imagine LED....Played some woodsball for about six hours the first time out with this gun and all went well great. Not a single chop..couldn't have been happier. Came home cleaned the gun inside and out. Last weekend, got together with some friends for another match and I had to look to make sure it was the same gun. I would shoot 5-10 shot on semi...then get a spudder...shot few more....spudder...chop a ball or two...squeegie....5-10 more shots....spudder. I had a couple buddies suggest changing the striker o-ring and bolt o-rings and did so without any change.

I use Co2 (full tank)...Good battery charge....Clean air filter...

I contacted a tech at Kingman and he didn't have any suggestions other than send the gun across the country for them to take a look at it. He did however, say that he had an idea what was causing the problem, but didn't want to send out parts until they could look at the gun...I wasn't looking for free parts...just abit of insight as to what may be the problem. Not much help there! I need to know how to troubleshoot the gun, not just send it in when I have a problem.
Today I had a bit more time to look deeper into the gun and found that the valve pin was quite scored and scratched. The valve appeared to be fine. So, I took some 800 grit paper and removed the scratches and scoring, changed the cup seal and valve o-rings since I was there, but didn't have a chance to see if that was the problem. Should the valve pin be scored like that after approximately 3500 balls and could this cause the problem? Any other suggestions?

druid
04-16-2006, 08:51 PM
it'll scratch if that's what you are asking...and replace your striker o-ring. lube it with grease...a dow 33 product like shocker lube

CBRuLater
04-17-2006, 02:42 PM
You are saying that the valve pin will be scratched as I have described?

I used Gold Cup oil on the striker and replaced the old o-ring.