PDA

View Full Version : trigger problems!


124
04-11-2006, 10:22 PM
I was trying to do that shorter trigger pull mod, but I guess that I accidentally poked out the wrong pin (the one actually ON the trigger). Anyway, when I pulled the trigger a few times, a small spring and a metal piece that, in my opinion, looked like a leg on one of those lego figures. Anyway, I'm going to guess that my marker wont work without these parts. Anyone know how to put these back in the trigger correctly? Actually, the marker is not a Spyder Xtra, but a Paradox MF1, which, in my opinion, is an xtra clone. So if the trigger cannot be fixed, could a replacement spyder trigger frame be put on (spyder trigger frame on a spyder clone). Thanks!

DRAGON
04-11-2006, 11:30 PM
Sounds like the spring and metal piece that trips the sear and ya, it's not going to work w/o it. You should actually be able to fit it back together. As far as that weird named marker goes, I have no idea if a Spyder mechanical will replace it. Sometimes they may be clones but suttle things like hole placement can be slightly off. The only way you're going to find out for sure is find someone with a mechanical Spyder and see if it fits -

124
04-12-2006, 06:45 AM
Thanks! But are there any instructions for putting it back together? My marker's manual doesn't go in-depth with the trigger frame.

DRAGON
04-12-2006, 10:11 AM
I have no idea since I never heard of that marker. Any pics of everything? -

ooglieboogliebob
04-12-2006, 07:30 PM
just buy a new trigger ... they're not really expensive ...