PDA

View Full Version : Viperblade and Velocity Problem


Team Ramrod
04-08-2006, 09:41 AM
Hey there,
I now have a problem I donít know how to fix. I got my new mag a week ago and it had a Viperblade trigger on it. I just got air yesterday and the trigger isnít allowing enough room for the sear to come out and actuate fully. There are no set screws on it so that isnít the problem. I know its the trigger because i swapped it out for the stock one and it corrected the problem. I'm not quite sure what to do, i could file down the top to give it more clearance, but I want to do that as a last resort. Any help you can offer would be great, its working but I would love to have the Viperblade in there for my game tomorrow.

PS, Anyone now the set-screw threads for the Viperblade? I got it second hand it doesnít have any on it, just thought id ask here instead of PMíing Rouge.


Ok, another problem. My velocity adjuster is impossible to turn. I have litterly bent allen keys trying to turn it out. I aired it up after getting it to shoot and it was venting out the back. I was able to turn it far enough so that it wasn't venting but now I cant turn it any further, it wont budge. Should I run some oil through it? That the only thing i can think of.

*EM1-Master*
04-08-2006, 10:07 AM
Should run oil through after every day of play... Viperblade issue, you probably need to adjust the sear...

Stuck velocity adjuster? Can always send to AGD.....

*EM1-Master*
04-08-2006, 10:09 AM
And I don't know the threads off the top of my head, but Rogue, TMS, etc... They'll all know, and they reply like lightning...

Team Ramrod
04-08-2006, 11:00 AM
Yeah, I pm'd him.

Thank god I have Gord, from Gord Designs, locally, Im going to take it to him as soon as i can, he is a life saver. Probably the only good thing around here paintball wise.