PDA

View Full Version : Spyder leak problem


Alex228
04-07-2006, 07:20 PM
yesterday I finally got around to making the va holes and valve hole larger. The va went very easy but I had some problems with the valve. After drilling the valve, there were some burs in the top, so i tried sanding it with 1000 grit sandpaper, After about 30 minutes of sanding i tried putting the valve in and it scratched some of the inside body, very little mind you. SO i took it out and kept sanding until it went in smooth, accidentally i sanded a bit of the top finish from the valve, but since its 1000 grit, it didnt really damage the piece. Anyways i put it back in and reassembled everything.

Oh also I just received my 32 degress kit and i put the weak valve spring in, only problem was that the thing end of the spring didn't stay on the cup seal, like the stock one comes out but u have to pull it out, this one just falls out. But when i put the 32* spring i had to balance the marker a bit so it wouldnt fall out when i put the pieces back in. I gassed the marker up and turned on the on/off.
As soon as I did that it sounded like it was leaking, I couldnt really tell from where but it sounded like the barrel, or maybe it was that little pin thats in the middle of the body, the pin that stops the valve when you put it in. Anyways I got my crap spyder thats thrown in my closet and swapped the valves, It stopped making that sound but I was having recocking problems, I put the stock spring back and it wasnt doing it. I put the weak valve spring back in and heard that the air was coming from that metal piece that holds the valve in place, the one that i mentioned before, so i pushed it in a bit more(by hand). Now i shoot like 20 shots or more, its not a specified number of times, and then all of the sudden eair starts leaking through my barrel.
Any1 have any ideas?

ad0131065
04-07-2006, 07:28 PM
....cupseal

Alex228
04-07-2006, 07:43 PM
i replaced it already. I'll try replacing it again.

NB_Hacker_NB
04-07-2006, 08:31 PM
yesterday I finally got around to making the va holes and valve hole larger. The va went very easy but I had some problems with the valve. After drilling the valve, there were some burs in the top, so i tried sanding it with 1000 grit sandpaper, After about 30 minutes of sanding i tried putting the valve in and it scratched some of the inside body, very little mind you. SO i took it out and kept sanding until it went in smooth, accidentally i sanded a bit of the top finish from the valve, but since its 1000 grit, it didnt really damage the piece. Anyways i put it back in and reassembled everything.

Oh also I just received my 32 degress kit and i put the weak valve spring in, only problem was that the thing end of the spring didn't stay on the cup seal, like the stock one comes out but u have to pull it out, this one just falls out. But when i put the 32* spring i had to balance the marker a bit so it wouldnt fall out when i put the pieces back in. I gassed the marker up and turned on the on/off.
As soon as I did that it sounded like it was leaking, I couldnt really tell from where but it sounded like the barrel, or maybe it was that little pin thats in the middle of the body, the pin that stops the valve when you put it in. Anyways I got my crap spyder thats thrown in my closet and swapped the valves, It stopped making that sound but I was having recocking problems, I put the stock spring back and it wasnt doing it. I put the weak valve spring back in and heard that the air was coming from that metal piece that holds the valve in place, the one that i mentioned before, so i pushed it in a bit more(by hand). Now i shoot like 20 shots or more, its not a specified number of times, and then all of the sudden eair starts leaking through my barrel.
Any1 have any ideas?







I seriously wouldn't drill my valve. Very minor scratches can cause it to mess up and you'd have to buy a new one. Buy a higher flowing valve.

Alex228
04-08-2006, 01:33 AM
I know but i put the stock valve from another spyder and it was still doing it.

NitroBall
04-08-2006, 07:14 PM
did you screw the cupseal onto the valve pin properly ?

take the valve out , and place the valve pin in.
see if the cupseal's face is flush with the valves body where they meet up.
a small scratch or imperfection from your drilling is enough for a leak.

can you post any pics up ?

does it leak before you cock the gun , or after ?

what strength valve spring are you using ?
as the weak valve spring can cause leaks due to the force of the main spring pushing against the valve pin.
it may stop leaking if you cock the marker.

have you put the small star shaped cupseal guide back in ?