PDA

View Full Version : Damned '04


NB_Hacker_NB
04-01-2006, 01:53 PM
What happens when your valve goes bad? Does it stop taking air completely? I put my FULL 72/3k on it, and for the first 2 minutes it was leaking a little from what seemed like the body, so I took out the valve and put it back in. I put the tank on, cocked and shot, nothing. The reg is turned up,nothing blocking the airway. I took off the LPC and no air is coming out, so i'm saying the air is stopping around the reg, because I took the reg off, checked it, and it was a little hot, just like n2 is supposed to be. Help!

ad0131065
04-01-2006, 06:30 PM
I dont think its the valve, Try raising the output pressure on the reg, lube and clean your reg, and make sure that there is no dirt or anything in your lines and fittings.

NB_Hacker_NB
04-01-2006, 08:27 PM
SORTED:The threads on the ASA,(a SystemX10),aren't far enought for my tank to fit fully into, thus the front of the tank,(the nipple where air comes through),is pushed too far into the ASA, causing the air to block and not be able to come all the way into the macro and reg. So now, I have to let the tank come out a little so air can come through into the macro fitting.Then it spurts through the back of the ASA because i'm guessing it can't find it's damn way to the macro.Man I am so frustrated. Also, this tank, for some reason, is very hard to put on. It must be screwed in alot more, I don't know if its because of the X or what, but i'm going to definetly need another ASA. (I traded it for a feedneck that didnt fit to someone I will not name). If anyone has any suggestions, they are very welcome to posting them lol.