View Full Version : MR3 shooting issue

09-22-2011, 09:57 PM
I have a MR3, When i have Paintballs in the gun, Air and a FRESH battery, I am havving issues sometimes ill pull the trigger and it will not fire.. nothign.. no flash from the LED.. pull agian and it will shoot.. I have checked the board everything looks fine. the tank is atleast half full

IF i have no air/paintballs it fires just fine.... the FPS is set at about 250ish

Does this sound like the board on the Egrip is going? if so is there still anyone out there that makes the Boards for this? i know its an older gun but i enjoy using it.


09-23-2011, 05:28 AM
do you have the eyes on or off? if you have them on try it with them off

09-23-2011, 10:56 AM
It does it Eyes on, Eyes off and Auto.

thats what i thought first.. thought the hopper was acting up. but it doesnt matter

09-23-2011, 11:10 AM
is you microswitch still clicking? is your capacitor still in good shape/not blown? I'd double check to make sure all wire plugs are plugged in all the way to the board

09-23-2011, 06:28 PM
Still hear the microswitch click, cap does not look blown/ no leaking. Im ordering a new micro switch , debating buying an aftermarket board... Just dont get why with no air/ammo it will click all day long... Add air/ammo and it randomly wont shoot(almost every other shot wont fire

09-23-2011, 11:43 PM
Right now i have just the board sitting on the bench.. it fires over and over Never misses a beat... It goes in the gun and it has issues.. I really dont get it