PDA

View Full Version : Spyder Electra ACS help!


jjackson003
07-11-2011, 10:39 AM
i just bought a used Spyder Electra ACS it looks great feels good but it doesnt fire properly i tried charging the battery but when i fire the gun it just fires once then the battery light flashes and the secondary safety comes back on :mad: i think the rechargable battery is toast but i dont know... Any suggestions would be great thanks

OtterSC
07-13-2011, 11:50 AM
wow... have not replied for how long?.....

anyways, welcome to the forum.

let me ask a few questions:

are you using the battery supplied by Spyder? you do need to use the 9.6v battery for your marker to cycle the trigger properly.

do you have full tank of air/co2? if it is low, this can choke the marker which can cause it to malfunction.

also, are you dry firing (shooting with no paintballs) or firing paintballs? some times when you fire a paintball, it helps with cycling the marker (recocking) after you pull the trigger. no paintballs may not have enough back pressure to recock the marker.

if you took the marker apart, it is a slim possibility that you may have swapped springs or something else was installed incorrectly.

i do not believe that this model has a regulator.

bigred76
07-13-2011, 01:08 PM
'Tis an electrical issue. Open up the grip frame and double check all your wires. Make sure they're all plugged in and that they are not frayed. You most likely need a new battery.

jjackson003
07-14-2011, 10:50 AM
ok i ordered a new battery and it came in today so im gonna go home and try it out tonight thanks guys!

TheDarkShadow
07-14-2011, 03:31 PM
yeah the new battery should fix it. If it hadnt switched to safety mode and had just clicked the solenoid when you tried to fire it, it would be the capacitor that would be bad (which is also a common problem with old electro frames)

jjackson003
07-26-2011, 09:34 AM
new battery fixed er up real nice thanks guys!!