PDA

View Full Version : Tippmann A5 issues


RSX99
01-26-2011, 09:35 PM
My brother picked up a brand new A5 and has been having a lot of barrel breaks and or chopping. I haven't been able to get a good look at it yet but was wondering if any of the gurus here know of any issues with this gun. Issues present with the following barrels and paint.

Barrels used: Stock
Dye Boomstick 14"
Phenom 16" sniper

Paint used: Vulcan
RPS Premium
Diablo Formula 13

WhatThaSmurf
01-26-2011, 10:02 PM
Hmm, could be something with the pressure. I haven't torn open an A5 in years, but I remember a whole lot of o-rings. It was crazy.

Anywho, you used different paint and different barrels, and if not for that I would say it was a bore-to-paint size issue. But that seems unlikely. Is it a barrel break, or a chop? I can see how the A5 feed system might become misaligned and cause problems.

druid
01-27-2011, 02:37 AM
Check the ball latch [detent] and perhaps change the cyclone paddles to squishy paddles from TechT

RSX99
01-27-2011, 05:50 AM
Thanks guys!

Arias
01-27-2011, 09:11 AM
As Druid mentioned check the ball detent and make sure the marker is not set to high fps. You will have to use a chrono for that. If your air source is low the cyclone will not have enough operating pressure to cycle the balls at which point you would have to do manually. If your paintballs are old and soft most likely they would get pinched in between the paddles and the feed. I also recommend you open up the cyclone and grease the feeder axle and ratchet (use grease on these), lubricate the spring and add a few drops of oil on the feeder reset rod.

druid
01-28-2011, 02:42 AM
..oh.......and take some 800/1000 grit sandpaper to dull the sharp "edge" on the hook on the right receiver.

RSX99
02-03-2011, 10:50 PM
Will do fellas. Thanks again!

Sandman_Bravo
02-20-2011, 02:11 AM
go to A5 OG = A5 Operators Group