PDA

View Full Version : I need help fixing my New 2009 Xtra


CarbineKid
01-17-2011, 09:47 AM
I recently brought a NIB Spyder Xtra09, and I need some help solving a leaking problem. I cock the gun and then I screw in my Co2 tank. When the tanks screwed in. the gun leaks at the asa. Actually there a small hole on the bottom and thats where its leaking from...all the time. I know the holes a pressure release point for the tank...but this isn't right. It should be leaking there all the time...right??? So whats causing this...and how do I fix it?? Edited due to my own stupidity. Guns fine tank O-ring issue
Thanks

Arias
01-17-2011, 10:58 AM
Have you checked the tanks o ring. Also take a look at the threads both on the ASA and on the tank. Make sure to screw in the tank with enough force to where the valve is seated at the back rear end of the ASA. If all fails contact Kingman and have your marker serviced. They have excellent customer service.

TheDarkShadow
01-17-2011, 01:17 PM
basically
a)something is stopping it fron screwing in all the way (possibly bad threading as stated above)
or
b)you have a bad o-ring or something is allowing the air to pass through where the asa and the tank meet

CarbineKid
01-17-2011, 01:51 PM
Darn it, now I feel stupid. I checked the O-ring earlier, but upon checking again I noticed a hair line crack/tear. I swapped out the ring and its fine now...thanks

Arias
01-17-2011, 05:05 PM
Darn it, now I feel stupid. I checked the O-ring earlier, but upon checking again I noticed a hair line crack/tear. I swapped out the ring and its fine now...thanks

No problem were all here to help each other!