PDA

View Full Version : chop chop chop!!!!


blind_side_america
03-17-2006, 11:14 AM
hola i use to do he form thing and it quit and now im back wit a huge problem my gun is a imagine and its got a lapco twist hopper feed with a empire twister barrel....and ya ....the gun gets mad break....would it be the paint or would it be the barrel? or something im missing..im pretty sure its not the barrel cause i used the stock and the one off my extra but they all seem to CHOP!!!!help please!!!:D

Hob Hayward
03-17-2006, 11:19 AM
Hmm, my favorite question, is it cold out? Stock bolt I presume?

If its cold, well spyders don't like cold, you could try oiling up your bolt o-rings...

And, how fast are you shooting?

blind_side_america
03-17-2006, 11:37 AM
ya stock bolt im looking toward getting a new one here soon...it wasnt that cold out but i dont feel the cold that sweal.....lol it was like 40 something....i wanst shoothing that fast....at points but i would shoot off like 10 rounds....then a break so i cleaned it and break in aboutb the next ten shots so i really dont know..

Hob Hayward
03-17-2006, 11:54 AM
I guess it could be your ball detent... thats the thing thats supposed to keep the marker from loading more than one ball at a time. I suppose you could try replacing it? It couldn't cost more than couple bucks.

NB_Hacker_NB
03-17-2006, 12:47 PM
The detent wouldnt be doing it...only one ball will be in the breach while the other sits on top. It would most likely be the paint or bolt. The stock Imagine bolt sucks madly. If I was you i'd get an ACS Delrin Bolt. It reduces chops greatly. Or, it could be the pressure your working at. If you havent move the velocity adjuster, that should be fine. Or it could be your paint. If your balls havent been wet it could be the paint to barrel match. Welcome to the forums.

blind_side_america
03-17-2006, 12:55 PM
ya thanks guys im getting a new bolt here soon hopefully...lol

caleb1210
03-17-2006, 02:14 PM
my spyder magine was giving me crazy problems too an it was my ball detent even though i thought no wy and now it works with stock bolt and wal mart paint

ShadowX
03-18-2006, 07:14 AM
yea check your detents, if they still spring in and out, then you are good. also what brand of paint were you using?? another factor is check to see how well the paint matches the barrel. it should just fit a LITTLE tightly and you should have to BARELY blow and the ball should come out. if its too big and wont go threw, then thats probably why you are breaking paint.