PDA

View Full Version : Air leak...WTF!!!


Ibuildmyguns
08-31-2009, 10:34 AM
Okay, I have a Spyder SE and have replaced every seal and o ring as well as bought a new bolt and new valve...I still have an air leak. It is coming out both the grip and out the barrel. Im about ready to just take the barrel, valve and bolt out and throw out the rest. I have had nothing but problems with co2 leaks and I am beginning to think the body has shot or something. Please help if you can.

DFSniper
08-31-2009, 11:27 AM
hmm. could be a gouge on the body. i think my imagine has that problem.

bigred76
08-31-2009, 10:14 PM
Put some DOW55 on the valve orings.

Ibuildmyguns
09-01-2009, 06:16 AM
Never heard of it. Where can I get it?

rayray88
09-03-2009, 12:14 PM
Check your bolt on inside your body maybe dirt got in there and scratched up the inside :(

oldironmudder
09-03-2009, 12:55 PM
Check your bolt on inside your body maybe dirt got in there and scratched up the inside :(

If his bolt scratched up the upper bore, that not going to cause a leak out the barrel & frame.

I would check the cup seal first. Since air getting through there will lead to both the barrel & frame. Then if that doesnt work, pull the valve out & check the oring very close. Replace if needed & lube them. Before you put the valve back in hold the body up to light & inspect the lower bore from the front to where the valve sits.

Dow 55 is a grease that has an oring sweller in it to help provide a good seal. Same stuff used on Timmys.

Ibuildmyguns
09-03-2009, 01:00 PM
Check your bolt on inside your body maybe dirt got in there and scratched up the inside :(

bolts brand new, but thanks. valve is new too as well as the o rings and cup seal. the spring isnt new though.

battlechaser
09-03-2009, 01:20 PM
Like Mudder pointed out, check your cupseal again, 99% of barrel leaks are caused by a scratched cupseal.

Fleperat73
10-12-2009, 08:11 PM
I was told the reason my filter doesnt build up pressure is because I have air getting in some where I lubricated the o-ring under the pump lid and it helped the flow. But Still no pressure. How do I go about finding an air leak