PDA

View Full Version : problem with fireing my mr2


viper91180
05-03-2009, 03:10 PM
hey guys, i picked up an mr2 used during the winter, never had a chance to use it, got it out the other day to get things ready and found that it will not fire, the previous owner said that he had no issues with it. i took the grip plates off and foudn that it seems the solenoid (or whatever it is) that kicks the tab is not hitting the tab at all, every now and then if i was to tap the thing it would fire. when i pull the trigger i can hear a light clicking noise, sometims the clicking gets louder, when this happens, the solenoid moves far enough to touch the lever, but not to push it, is this something common or did i get a lemmon? thanks for the help in advance

bigred76
05-03-2009, 05:28 PM
How is the charge on the battery?

viper91180
05-03-2009, 05:48 PM
crap, i should have remembered to mentione that, its was a new battery when i got it, and i charged it up for about 6 hours yesterday. i did plug in in again tonight, just incase that wasnt long enough, but i think it should have been shouldnt it? at last to fire it a few times

slim and shady
05-03-2009, 08:34 PM
that happens alot wiht the MR2 when it sits or if the grips are to tight. usually a little tap frees it up. or place something thin behind the selinoid. I used a peice of thin plastic behind the selinoid and it worked like a charm others have used like a dime or penny. try it and see if it helps.

viper91180
05-04-2009, 01:05 PM
ill give it a try, when you say behind the solenoid, do you mean the large round surface towarsd the back of the grip frame?

slim and shady
05-04-2009, 09:26 PM
yup

bigred76
05-04-2009, 09:44 PM
Behind the part of the metal clanky thing that moves. You want to shorten the throw so it doesn't take as much power to release the striker/drop the sear.

viper91180
05-05-2009, 05:42 AM
i put a dime in, and tried a thin piece of plastic, but when i put anythign in it just made a really light click and wouldnt even move the solenoid, when i take it out, like i said its hitting the sear, but just not enough to move it, the back end of the solenoid is not going ahead all the way either, not sure but to me its maybe looking like a weak solenoid? does this happen?

bigred76
05-05-2009, 06:27 AM
The solenoid is an electromagnet and theoretically could not wear out. My bet's on the capacitor, though. Send it into Kingman if it's still under warranty.

slim and shady
05-05-2009, 08:10 AM
Hat had the shaft that goes in and out break in half. Never heard of that before so I guess anything could happen. MR2 have this problem alot actually they just stop working for no reason.

viper91180
05-24-2009, 09:02 AM
ok, so i havent gotten anywheres with this yet, there just isnt enough power in the solenoid to move the sear, i dont know where to go from here, theres no warrenty on it, and theres no one around here to do repairs, so, is my best bet to try and find a use assembly, the gripframe? or is there anything else i can try, someone mentioned the capacitor, is that something that is common, im sure i can find one around at the local electronics store.

slim and shady
05-24-2009, 12:40 PM
Im sure your problem is in your selinoid. assuming of corse you are using a GOOD CHARGED 9.6 volt battery. Take the selenoid out of the frame by loosining the set screws that go down from the top. make sure its clean ect. put it back in but move it a little closer to the back of the trigger frame.
Im sure there is nothing really wrong with it as all my MR2's have had this problem. its just that the throw is to long thus not enough power to trip the sear. Try it let me know.

viper91180
05-31-2009, 06:49 PM
well i had a chance to get the trigger frame off today, and i tried adjusting the solenoid, but there is so little amount it can move that it did not make a difference, im gonna play with it some more, but in the meantime any other suggestions? im looking into a used trigger frame right now, if i have to ill go that route to get it working

viper91180
05-31-2009, 07:08 PM
also, i was just playing with it again, and i dont think its a matter of not haveing enough travel because with the frame off the gun, i can just hold a very slight bit of pressure against the trip mechanism and i get nothing, the led is blinking or dimming indicating that its trying to fire, but theres just no power whatsoever in the solenoid

bigred76
05-31-2009, 07:25 PM
Prolly the capacitor then (big black thing attached to your board). See if it's bulging anywhere.

Griff
06-01-2009, 06:40 AM
http://www.sundragonpps.com/catalog/item/4688306/4734476.htm
Good place to get parts from.

viper91180
06-01-2009, 12:30 PM
thanks, that site described just exactly what was going on, sounds like the capacitor to me, i clipped it off and took it with me to try and find it locally, (with no luck) and the gun operated the same, which leads me to believe it is not functioning at all. so i went to order from that site, and they dont ship to canada lol, of all the luck

slim and shady
06-01-2009, 06:17 PM
get it shipped to Tim and have him ship it to you. I can vouch for him, helped me out a few times. Im in Canada too. Send him a PM and see (Bigred76)

bigred76
06-01-2009, 11:02 PM
Or you can PM Sundragon on these forums (I'll search for his username in just a couple minutes) and ask if he will. He's a nice guy, so he might just do it. I do know how to solder (if you don't or aren't willing to learn) and would be willing to help out if Mr SPPS wouldn't be able to. It's no sweat off my back, you'd just need to wait a couple extra days for it to get to me (he's in Florida and I'm in Cali) and would have to pay for the extra shipping.

I'd also look for a local electronics surplus store. I live in Silicon Valley and they are literally everywhere, and I don't know how it is in Canada. It sounds like you already tried that route, though.

Just let me know in a PM whether or not you need some American help, I'd be glad to.

viper91180
06-02-2009, 02:10 PM
thanks for the offer, i really appreciate it, i tried the local route and there is nothing around here, but i did source them at an online store here in canada, and ordered two of them, hopefully they will be here within a week or so and ill be able to get it up and running!!

sonik
06-02-2009, 06:13 PM
In Canada, you can order from either Active Electronics or Radio Shack(the source)

the cap is a Jackcon 6800uF16v

I have heard if you email this address you can ask for a sample and they ship for free. -> JACKCON@MS14.HINET.NET

this is from a year ago but may still work:

please provide your full address by return, we will able to send you the samples of 6800uf/16V for replacement.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
JACKCON CAPACITOR ELECTRONICS CO., LTD
HONJU TAIWAN CO., LTD.
TEL:+886-2-2278-2210
FAX:+886-2-2278-2640
+886-2-2278-2656
E-MAIL: jackcon@ms14.hinet.net
MSN:jackcon@ms14.hinet.net
Skype:jackcon-john
Yahoo message:jackcon_john@yahoo.com.tw
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

thanks for the offer, i really appreciate it, i tried the local route and there is nothing around here, but i did source them at an online store here in canada, and ordered two of them, hopefully they will be here within a week or so and ill be able to get it up and running!!

viper91180
06-03-2009, 04:31 AM
just thaught i would let you know that i sent an email to those guys and inquired about a sample, and i got a reply this morning stating that 4 caps of that value were sent out to me, and they provided a tracking number!

viper91180
06-20-2009, 06:57 PM
hey guys, jus thaught i wouuld let you know that the cap came in a few weeks ago, so i got it installed the otehr day, marker works great now!! thanks for all the help guys, was appreciatede