PDA

View Full Version : My Gorgeous Sniper


SpyderMan723
04-01-2009, 12:54 PM
http://farm4.static.flickr.com/3650/3451557690_b0350abcdc.jpg
http://farm4.static.flickr.com/3369/3451547150_318ee91ba3.jpg
http://farm4.static.flickr.com/3379/3450730009_03c0d33387.jpg
http://farm4.static.flickr.com/3650/3450728955_b9a08fe525.jpg
http://farm4.static.flickr.com/3586/3451545764_2d93e329c8.jpg

ferret15
04-01-2009, 03:59 PM
nice.

Sandman_Bravo
04-01-2009, 04:05 PM
Very nice.

xsvly-fat
04-01-2009, 07:56 PM
Nice. Looks light.

especiialypsycho
04-01-2009, 07:59 PM
Its missing a reg and ASA.. FAIL :dodgy:

hawt gat bro

SpyderMan723
04-02-2009, 10:42 AM
thanks guys.

psycho: GTFO

:D

codymm1014
04-02-2009, 02:15 PM
Looks really nice.
But you have to do something with that feedneck...

RSX99
04-02-2009, 02:38 PM
I thought taller was better?!?

SpyderMan723
04-02-2009, 03:15 PM
OG status

TheDarkShadow
04-02-2009, 05:56 PM
looks nice man.... suprise, surprise, it's blue

DFSniper
04-02-2009, 05:58 PM
what frame is that. i think i may actually like something on that gun :D

SpyderMan723
04-03-2009, 08:10 AM
looks nice man.... suprise, surprise, it's blue
hahaah
what frame is that. i think i may actually like something on that gun :D

CCM frame

DFSniper
04-03-2009, 01:13 PM
ooh. just a regular 45?

SpyderMan723
04-03-2009, 01:15 PM
ooh. just a regular 45?

yessur

Modded-Like-Hell
04-03-2009, 01:45 PM
nice...still a virgin i see

Critical
04-03-2009, 02:08 PM
The only thing worthwhile that Egos have contributed to the world is their feedneck. That sniper is just asking for the mod.

codymm1014
04-04-2009, 10:12 AM
DOT.
and its easy to do. So worth it.

SpyderMan723
04-07-2009, 11:58 AM
so my sniper is having some problems.... when i air it up it leaks out the front hole.. i loctited the pump thingy that screws into the hole and it still leaks.. maybe the input pressure on my reg is too high, or my IVG is screwed in too far?

Team Ramrod
04-07-2009, 12:19 PM
the front pneus hole, the one where the pump guide rod screws into? There should be o-rings on either side of the mounting plate, try taking it of and check the condition of them and try giving them a little lube.

bigred76
04-07-2009, 01:38 PM
Give them some nice DOW55. Swell those suckers up.

codymm1014
04-07-2009, 04:36 PM
Make sure you have an oring on the pump guide rod. Then you could always teflon tape the threads on it up too.

Modded-Like-Hell
04-07-2009, 08:09 PM
the pump guide needs loctite and an o-ring with some dow55

SpyderMan723
04-18-2009, 10:50 AM
new pics

Modded-Like-Hell
04-18-2009, 11:14 AM
sweet