PDA

View Full Version : imagine wont fire sometimes!!!!


tinym80
01-20-2009, 10:13 AM
:confused: Hey guys! Im new to the sport. My imagine wont fire sometimes. It will only work with a 9V rechargeable and not with a 9.6v java. It just clicks sometimes (with the 9v) but not enough power to trigger the bolt. I usually disasemble and put back together and it starts working again. What could this be?

TheDarkShadow
01-20-2009, 10:25 AM
so it doesn't work w/a 9.6v? that's odd. how old is the 9.6v battery? it may be fried and you might want to get a new one

fernando8877
01-20-2009, 04:36 PM
try using a new 9 volt if its just clicking with your current 9 volt.

druid
01-21-2009, 01:07 AM
:confused: Hey guys! Im new to the sport. My imagine wont fire sometimes.

1. It will only work with a 9V rechargeable and not with a 9.6v java.

2. It just clicks sometimes (with the 9v) but not enough power to trigger the bolt.

3. I usually disasemble and put back together and it starts working again. What could this be?

1. a 9V rechargeable IS 9.6V. "Java" is the brand name. As long as the 9.6V is rechargeable, the brand name doesn't matter.

2. Because the noid requires 9.6 volts to power it. a 9C Alkaline won't have enough power beyond 25 or so shots.

3. There are usually two fixes.
A.) Get a new 9.6V battery and initially charge it for 12-16 hours and then play.
B.) The sear is binding on the striker.

For B, polish your sear on top and the back. Also polish the striker on the bottom, where the sear locks into it.


try using a new 9.6 volt if its just clicking with your current 9.6 volt.

Fixed. a 9V doesn't do it for Spyders...I think that was just a mis-speak on your part.

tinym80
01-21-2009, 09:27 AM
I tried my 9.6v and nothing. I tried a friends 9.6v nothing(fully charged). I tried a basic 9v nothing(new). The rechargeable 9v just clicks(rayovac), sometimes fires. My other imagine and my friends imagine works perfect with all?? I am waiting for another friend to bring me his batteries, hopefully they will work. Also, im not too familiar with parts or their names so i dont know what the sear is. Any extra help will be appreciated. Thanks guys.

TheDarkShadow
01-21-2009, 07:18 PM
look in the manual, it is the thing on the trigger frame that drops and lets the striker go forward (you probably didn't get that... so look in the manual)

Lybster
02-04-2009, 10:11 PM
Try recharging your 9.6 volt battery, but don't overdue it (2-4 hours should be fine). Remeber the recomended battery for Spyder e-grips is the 9.6 volt, save the 9 volts for the hopper.

rem2500
04-20-2009, 06:55 PM
Did you ever figure out the issue? I am having the exact same problem. My Imagine will click but it never actually releases the bolt. When I look at the process with the grip off, it looks like the solenoid has given up to me, as it doesn't move very much when I pull the trigger.

I just bought a brand new 9.6v battery for it to make sure that wasn't the issue. My next move is to purchase a new solenoid, but I wanted to get some advice before I spent the $$ because they are way more then I thought they would be...

Thanks,
REM2500

big_daddy_d
09-14-2010, 04:31 AM
could be a wiring issue or the capacitor on the board may have come loose, not giving the solenoid enough juice to release the sear... look on your board top left corner should see a cylindrical thing soldered to the board... see it the soldering hasn't crapped out on you...

druid
09-14-2010, 11:22 PM
or the grip plates are too tight, squeezing the clapper on the noid...