PDA

View Full Version : Overall Problem


msu136
09-05-2008, 10:51 PM
I got a VS1 not to long ago. I have take the whole thing apart and looked at every inch of it. I am using CO2 and when I fire it will shoot a good one then it will barely spit out the next one. It is not staying cocked. I have to re cock it to fire again. Any ideas. None of the o-rings look bad just doesn't seem to fire right. Thanks

Hossy
09-06-2008, 05:13 AM
Oil the gun, make sure that the bolt is not upside down, the striker is in the right spot, and that the Valve was put in correct.

Welcome to the forums, check the Ultimate Resource Thread in my sig (below this post)

Blue Spyder
09-06-2008, 09:03 AM
Welcome to the forums. I had the same problems as you. What you need to do like "Hossy" said is Oil your gun. Every O-ring you see you should oil it. It really helps. The oil I use for my VS2 is "Extreme Rage Oil". I suggest you buy it and oil your gun. Also oil the O-ring on your bolt and put 2-3 drops in your ASA and fire the gun a few times.

Gold cup is also a good brand.

Paintball Freak
09-06-2008, 02:04 PM
Also, (just a thought), my VS1 would do that sometimes but I found out that it wasn't fully charged.

Blue Spyder
09-06-2008, 04:11 PM
Also, (just a thought), my VS1 would do that sometimes but I found out that it wasn't fully charged.

Yah. He is right. Make sure your battery is fully charged. Having a low battery can have huge cocking problems.

Griff
09-06-2008, 08:25 PM
Was the bolt or valve put in upside down?