PDA

View Full Version : Trouble with MR2 Spyder with eye


Dustin'sspyder
07-15-2008, 05:40 PM
Hey i was play n a 12 hour game of paint ball Saturday and was using my mr2 spyder with eye in the game around 10 hours into the game my gun started to chop paint balls and eventually wouldn't shoot. I checked my light on my guns handle and it started blink in green which meant the eyes weren't working so i cleaned my gun put all back to gather and tried to tested it and the gun shot a paint ball more than 2 feet and the bolt in the gun wont automatically reset to shot another paint ball. If anyone knows what might be happing to my gun please help me.

DRAGON
07-15-2008, 05:52 PM
My guess: You put the striker buffer in front of the striker instead of in back of it where it's supposed to be -

slim and shady
07-15-2008, 05:56 PM
^ I agree this seems to happen alot more then people realise!

Dustin'sspyder
07-16-2008, 07:21 AM
Im just new to playing paint ball so you probably have to tell me what everything is. I haven't really taken my gun apart just the barrel and the feed neck along with pulling out the eyes out of the hole and clean n them. So whats a striker buffer?

Jungsa
07-16-2008, 07:31 AM
The striker is connected to the bolt, it is below the bolt. the buffer is a donut looking thing that should go behind the striker not in front. but it does not sound like you pulled your bolt out... I am at work and cannot open the diagram for some reason. maybe someone else can give you the #'s to the striker and buffer...

Dustin'sspyder
07-16-2008, 07:51 AM
looking down the barrel there is a white piece toward me and looking down the stock there is a black piece is this the right order?

Dustin'sspyder
07-16-2008, 08:00 AM
I'm looking at the mr2 with eyes schematics in my user guide but ive never taken anything but my barrel off my gun before spyder should of put everything together right? But I'm think n that my gun isn't get enough co2 because it will shoot a paintball but not far and the Delrin Bolt wont re cock itself

slim and shady
07-16-2008, 08:01 AM
Well if you didnt take the internals out that wont be your problem, So im going to ask if your air tank was full? When it shot 2 feet did your gun make a big bbbbbuuuurrrrppp sound and then wouldnt recock. If so you are just out of air fill your tank up.

Dustin'sspyder
07-16-2008, 08:09 AM
no i have air. i put the same tank on my brothers mr1 and it shot perfect. You think it might be leaking somewhere?

slim and shady
07-16-2008, 08:18 AM
You should hear it if its leaking, did you try to put it back on your marker after you put it on your brothers MR1? sometimes if the tank is turned in to far it will cut off the air flow. Do you use a remote?

Also you said that you were chopping paint bad your bolt will be covered in paint and there may be a peice of a paintball shell that is jamming the bolt this is common to its why you should take your marker appart and clean it. Just take the marker appart and pay attention to what order everything comes out. Clean it all up and pput it all back in that probably will solve your problems. Also check your detents to make sure they are in good condition since your "Maintaning" your marker. one is under the left eye cover and the other is under the feed neck.
The first thing you should do is clean your bolt and internals then re oil your striker ring (Red oring) and other o rings you may see then put it all back together. When you have your internals all out be sure to run a clean battle swab through the boy of the marker to clean all the paint out of there.
Do this and try it then let us know.

Dustin'sspyder
07-16-2008, 09:06 AM
I tired putting the tank back on and the tiny hole where the co2 screws in shot co2 for a good 7 secs before i took it off is there suppose to be a o ring in the connection where the tank screws onto the gun? I'm not using a relocator

Jungsa
07-16-2008, 11:58 AM
Does the MR2 w/ eyes have the ati chop bolt as well? because in 2006 I was in a game and my bolt broke. I saw a silver thing shoot out about 10' and noticed my velocity DROPPED real bad. I picked up the piece and walked off the field. this piece went INSIDE of my bolt, the piece the spring goes around. I emailed Spyder about this and they replaced it no questions asked at all. seriously awesome customer service. Anyways you might want ot check your bolt. could be all gummed up. or broke like mine was...

I believe you are supposed to have a o-ring on your tank is that still there?

*Edit That was the last game I used CO2, I honestly think the CO2 froze the bolt causing it to break. but who knows.

Dustin'sspyder
07-16-2008, 12:23 PM
Yeah it has an anti chop bolt but i think its more along the lines of the co2 not getting to the gun i connected the co2 tank on to the gun and started hearing a hissing noise so I think its leaking somewhere. Its that or i just overtightened the co2 to the gun causing the gun to leak. My delrin bolt wont recock either so I about 95% sure that its the co2 but it might be like you said the anti chop bolt coming loose.

Dustin'sspyder
07-18-2008, 11:01 AM
Fixed the problem i took my spyder apart and took the striker bolt out and oiled it and the bolt above the striker bolt i took out and there was some paintball residue above it and i cleaned the whole area where the bolt was and put it all back together and it shoots fine now. Thanks for all the help!

slim and shady
07-18-2008, 04:29 PM
Also you said that you were chopping paint bad your bolt will be covered in paint and there may be a peice of a paintball shell that is jamming the bolt this is common to its why you should take your marker appart and clean it.

:dodgy:

sonik
07-18-2008, 05:36 PM
You were so right... at least Dustin posted back and didn't just vaporize leaving us all wondering what the problem was. :)

Nice catch BTW...

:dodgy: