PDA

View Full Version : First problem, I'm not the only one....


ElPiloto
02-26-2006, 02:44 PM
Hi, I saw this problem in a diff thread, It just happened to me and I noticed it while cleaning my gun. I've probably shot around 6000 balls with this gun so far. THe Striker bolt plug (P/N 23FA) broke off. THis part covers the ACS Venturi Bolt.

Other than dirt getting in is there anything else i should be concerned with?

http://img153.imageshack.us/img153/7106/brokenbolt4wx.jpg (http://imageshack.us)

http://img153.imageshack.us/img153/7776/gunandbolt4ki.jpg (http://imageshack.us)

Spyder Pilot ACS
Dye Sticky 3 Grips
CP 14" barrel
Trinity T-Lock feedneck
Evolution II hopper

ooglieboogliebob
02-26-2006, 06:25 PM
nope, it should be good ... other than what you were saying .. but then again .. it's still prone to dirt because of gap of the cocking knob ... and look at the rear cocking knobs ... even more exposure ...

No problem at all though .. shunut does have one avaliable if you want one in the BST forums. I would just suggest to grind it down a bit to make it less sharp .. and a bit neater :p

ElPiloto
03-01-2006, 10:28 AM
I was finally able to get a hold of someone at kingsman. Just have to email them the warrantee card and they will send out a new part. Dang, it only took 3 days of calling and being on hold 4 ever.

ooglieboogliebob
03-01-2006, 01:50 PM
hmm.. sending an email probably woulda been faster .. :p

ElPiloto
03-01-2006, 04:26 PM
I emailed them on Saturday and they never replied.

bigred76
03-01-2006, 04:36 PM
It's because of the marker's blowback. It should be fine now so long as you make it not have any pointy edges and you have your striker buffer still. :)

ooglieboogliebob
03-01-2006, 06:25 PM
hm ... kingman usually takes about a week to reply ... just be patient .. :p ... well .. actually nexttime .. since your done now

Rastaskater
03-02-2006, 10:58 AM
I emailed them on Saturday and they never replied.


It was me who had the problem, all you have to do is email them, explain what happed and theyll send you a new one. In fact they didnt even ask for a serial number or anything, they also responded to my emails in a few hours.

ooglieboogliebob
03-02-2006, 02:22 PM
hm... thats what i thought .. since i'v asked kingman quite a few things before .. but they usually reply asap

ElPiloto
03-02-2006, 03:46 PM
HHHmmmm, I emailed them and they never replied. Also the Tech said I had to scan my warrantee card and email it to them. Darn I cant find it!!!!!! Maybe I should just call/email again and see if I get someone that wont ask for it.