PDA

View Full Version : Spyder RSX and Empire Magna Loader issues


tingkka
05-05-2008, 03:54 PM
I'm trying to use my Magna loader with my RSX but the top is not screwing down hard enough. It keeps falling off. Is there a way where i can get that screwed on tighter or am I not doing it correctly? I just got my RSX, so i'm fairly new with the marker.

Cmudge26
05-05-2008, 04:15 PM
I'm trying to use my Magna loader with my RSX but the top is not screwing down hard enough. It keeps falling off. Is there a way where i can get that screwed on tighter or am I not doing it correctly? I just got my RSX, so i'm fairly new with the marker.

put the hopper in... screw up and then screw all the way down till it gets tight... if that doesn't work switch to Feedneck Clamp about $25-$30. I have RSX right now and im having problems with mine :mad: so yeah....

OSOK
05-05-2008, 04:24 PM
If the RSX has the twit lock clamping feedneck like the RS you just twist it so it is close to coming off, put the hopper in, then tighten it. With my Empire B it can turn in a circle, but not slide off.

tingkka
05-05-2008, 04:39 PM
yea... i have clamp this pretty tight on there. it works though. doesn't really move around until i force it to move around. however, i did end up with a blister on my left hand trying to screw this on.

thanks for you guys' input and help.

Cmudge26
05-05-2008, 04:43 PM
yea... i have clamp this pretty tight on there. it works though. doesn't really move around until i force it to move around. however, i did end up with a blister on my left hand trying to screw this on.

thanks for you guys' input and help.

I hope your RSX doesn't mess up like mine did... read my thread... titled " Spyder RSX PROBLEM...? Help..."