PDA

View Full Version : E-99 won't fire


aadepa
03-03-2008, 09:52 AM
Ive got an e-99 i bought new, but was only about to use 3 or 4 times. I tried using it the other day with a full tank and fully-charged battery but it didnt fire. When the trigger is pulled it makes a little click but nothing happens. I brought it to my local paintball place and they held it for over a month without looking at it because they wanted me to buy a new gun, and then had the nerve to try and charge me when they didnt do anything to it. So any help is appreciated.

shunut
03-03-2008, 03:19 PM
Even though you fully charged the battery, it may be bad. Sounds like the 'noid isn't pushing out enough power to trip the sear. I would get a new 9.6v rechargeable and see if that works. Make sure its a 9.6v rechargeable battery, if its not it will not work.

You might also want to take the marker apart and make sure the striker isn't stuck and that it is well lubed and very of any dirt.

Try that and let us know.

druid
03-03-2008, 10:56 PM
Yes, replace the battery with a new 9.6v and 180 -to- 220 mAh battery. Radio shack or other electronics store would have them.

also...the noid. Remove it and clean out any gunk in the clapper and polish the copper ring.

Check the board's capacitor (large black cylinder on top of the board). It should NOT be leaking any fluids and the ends of it should be absolutely flat. If either end seems like it's "bulging" (or it's leaking a dark fluid) it's bad and needs replacement. Again, radio shack has replacements.

SpyderMan723
03-04-2008, 05:15 AM
Check your grips to make sure they aren't on too tight to be restricting the noid from moving.

aadepa
03-04-2008, 05:31 AM
thanks, i'll give that a shot this weekend when i can refill my tank. Appreciate the suggestions.

tumtum00
03-14-2008, 07:25 AM
od you still have the stock board in it ?

aadepa
03-17-2008, 12:34 PM
yeah, it's all stock.