PDA

View Full Version : Air Leak In Barrel


poker_jake85
02-21-2008, 05:26 PM
I heard air leaking down my barrel. I was told it was cup seal, so I took my vs2 apart and replaced it. It didnt look bad but still replaced it. I checked all O-Rings, they looked good so i put it back together and gassed her up. Still leaking but not as much. any suggestions?

king-man
02-21-2008, 08:06 PM
Just outta curiostiy, do you have a trinity body? this is a common problem with them, is it a costant flow or does it do it after shooting fast.

EDIT: Did you lube it while you had it apart?

poker_jake85
02-21-2008, 08:28 PM
I do not have a trinity body. Constant flow, but as soon as I cock it it stops. You can only hear it when you put your ear up to the end of the barrel. Before you could hear the leak just holding it. I did lube it, but I have rifle lube that I use for my .30-06. I heard rifle lube does work but i might have to invest in some paintball lube.

deano 177
02-22-2008, 05:55 AM
Is this something that just happened or is the marker brand new? You may just need to lube the hell out of it. If there is some trash on the seat of the cup seal it will cause problems. When I put a palmer's reg on my mr1, a small piece of metal went into the line and wound up on my cupseal. I had hooked up the air the night before and the marker shot fine with no leaks. The next morning I put air on it and it was hissing down the barrel just like you describe. I put a bunch of lube in the ASA and everywhere else. I went straight to the cup seal and pulled it out. It had a small sliver of metal across it and had gotten stuck in the cup from all the firing. I put a new one on there and she works like a charm.

king-man
02-22-2008, 07:30 AM
:yeahthat: rifle lube should work but did you take the entire valve apart?

poker_jake85
02-22-2008, 09:46 AM
It just started to happen. I just got CP Reg, Cp Drop, Cp ASA, and Tadao board. I havent used it since last fall, since I live in minnesota. I put all the stuff on and heard the hiss out of the barrel. I took everything apart, but gonna do it again and look for metal pieces. So it has to be in the valve? not the striker or bolt?

poker_jake85
02-22-2008, 10:12 AM
Thanks you guys. I replaced every O-Ring. Soaked the valve in lube for hours...lol jk, but i did lube it good. I aired her up and no hiss. Hopefully it stays this way. I found a couple loose o-rings that looked stretched, especially the one inside the valve. Again thank you. Hopefully when move to Jacksonville I wont have to go so long without playing....lol

swoosh81
02-22-2008, 01:49 PM
It sounds like the valve set screw was to tight.