PDA

View Full Version : MR2 hickup


slim and shady
02-12-2008, 03:34 PM
recently my MR2 has been hickuping and acting like it is out of air. This happens regardless if im outside or inside in the warm. I know that the tanks I have tried are full. I tried my HPA and a 20 oz Co2 both with the same affect. I tried with or without the coil to the same effect. does anyone have any sugestions why my marker seems to be getting a lack of air even though it was fine when i cleaned and oiled it at the end of last summer season?

SpyderMan723
02-12-2008, 04:18 PM
This was happening to me when i first bought my MR2.

The air is probably being blocked by something.. lube it?

take off the line and check your little reg/ex chamber thing.

Tigerwolf
02-13-2008, 02:27 PM
Did you by chance take out the valve body and spring if so make sure the valve body is not upside down. Old spider valve bodies were milled right thru so it did not matter if the valve body was upside down the new ones are not milled all the way so there is an up and down.

slim and shady
02-13-2008, 05:00 PM
uuuhhhh i dont think so but now that you sugest it im gonna just rip it appart and check anyway. Thanks

painkiller
02-15-2008, 02:55 PM
Did you by chance take out the valve body and spring if so make sure the valve body is not upside down. Old spider valve bodies were milled right thru so it did not matter if the valve body was upside down the new ones are not milled all the way so there is an up and down.

My gun was having the same problem a couple months ago and it turned out to be my valve being installed the wrong way as tiger described in his post.

slim and shady
02-15-2008, 04:22 PM
ok i took it apart and cleaned and oiled everything again and put it all in the right way havent got a chance to check it again though. soon as i do i will let you all know.