PDA

View Full Version : I think my gun may be leaking!


HavocNC
02-02-2008, 05:18 AM
Well yesterday when I was shooting it performed great, but I had two jams but the balls did not chop, When I took the hopper off to push the ball down into the chamber I could hear the hissing of the CO2 coming from the chamber it was a constant his so I shot the ball out of the chamber and it was still going, I don't know if this is the sign of a leak or maybe I am worrying about nothing. It would be nice if someone could tell what is happening.

keeperkys
02-02-2008, 01:25 PM
You may have a leaky spyder bolt o ring

SpyderMan723
02-02-2008, 03:53 PM
Well yesterday when I was shooting it performed great, but I had two jams but the balls did not chop, When I took the hopper off to push the ball down into the chamber I could hear the hissing of the CO2 coming from the chamber it was a constant his so I shot the ball out of the chamber and it was still going, I don't know if this is the sign of a leak or maybe I am worrying about nothing. It would be nice if someone could tell what is happening.

throw some oil into the asa and shoot a few times

HavocNC
02-04-2008, 10:48 AM
Yea it is affirmative my gun is leaking or something TERRIBLY I shot today after I put some lube in the asa and it just started hissing through the feedneck really loud and then after about 100 shots alot of CO2 smoke started coming alot more than what usually comes out and also my fasta loaders feedneck is cracking I don't know how this is happening it wasn't cracked a week ago and thanks to the weather I have not been able to play for a week I have never dropped it all I did was put it in my clamping feedneck and shoot it. I don't know but kingman is really starting to tick me off if this keeps happening. but back in the point of the leaking if someone could tell me what may be happening please respond because I am really starting to get ticked.:mad: :mad:

deano 177
02-04-2008, 11:38 AM
Check part number 12 (http://www.spyder.tv/section/support/diagrams/mr2.pdf). Your cup seal may be letting air by. You should have got an extra one with your parts. Change it out and report back.

SkinWalk3r
02-04-2008, 11:42 AM
Check part number 12 (http://www.spyder.tv/section/support/diagrams/mr2.pdf). Your cup seal may be letting air by. You should have got an extra one with your parts. Change it out and report back.

yup.Its a small white round "nubby piece" . It should be in the small zip lock bag along with the spare O-rings etc.

HavocNC
02-04-2008, 12:39 PM
Will I have to completely dissemble my gun to do this?

HavocNC
02-04-2008, 01:39 PM
Guys.... I thank god, for this forum and all of everyone's help that people give. Now that I have replaced my cup seal it is not leaking. Now that I have had to take apart the gun now I know how everything works and is encouraging me to start trying to mod this gun. I see a resemblance to an mp7 without the shroud and foregrip on the gun. (just a suggestion to a more experienced modder out there!) Just another thanks to everyone.

goldengod_16
02-21-2008, 11:05 AM
First off i just bought my mr2 two days ago now, i used it for one day (about 400 rounds) and then half way though it stoped fireing, the trigger got lose and wasnt holding the bolt. but i had stripped the gun to make sure it was nothing more.

now it wont stop leaking. its coming form the valve, i tryed changing out the cup seal, and it didnt help nor did changing all the rings, only thing i didnt do is lube im going to try that after work today, but is there any thing else i might have missed?

pb34
02-21-2008, 11:37 AM
Make sure the cupseal isn't nicked or anything. Even if it doesn't look wrong it may still leak. Try lubing up the o-rings on the valve and see what happens.