PDA

View Full Version : T-board not clicking


king-man
01-14-2008, 03:51 PM
ive got a tboard and all of the sudden i was pulling the trigger and it stopped moving the solinoid, i jsut figured the battery was low so i put ina fresh batterey and it still wouldnt move, its not the triggerswitch because the lite blinks, any idea of what idea of whats wrong? I made sure all the wires were connected good. Could it be my soliniod or my board

VS2 King
01-14-2008, 04:22 PM
Did You Check To See If The Eyes Are Off?

king-man
01-14-2008, 04:40 PM
ya i pushed the eyes off buttin and still nothing

MVS1
01-14-2008, 04:46 PM
Check to see if the "EP valve enable" jumper fell off, if your not sure what that is look here...http://www.scenariodreams.com/manuals/electra_verc_manual.htm, scroll to the bottom of the page for the visual, it's right next to the socket for the Noid.

king-man
01-14-2008, 05:01 PM
no luck, i pushed down on it and it dint budge, guess ill keep the stock board in my vs2trigger im gettn

MVS1
01-14-2008, 05:08 PM
Contact Damon, he is awesome about taking care of problems, he just fixed my board that I jacked up by plugging the battery into the noid socket (never drink alot of beer and work on your marker:o ). I told him what I did and told him I would pay for the repair. He fixed it and sent it back and won't let me pay him for it. Damon, stands behind every board he sells 100%, no questions asked. I'd give that a shot before you throw in the towel.

king-man
01-14-2008, 05:39 PM
when i get my new vs2 trigger(comes tommaro:D)im gonna try and c if my noids bad, if the noid does work, suks for me, if it doesnt ill send it back