PDA

View Full Version : bolt only cocks halfway back


kramernator
01-11-2008, 07:23 PM
i have a sprint frame on my rodeo (pretty old, but in decent condition)
http://i267.photobucket.com/albums/ii308/mkramernator/PHTO0097.jpg

when i hold in the trigger (fully auto) after about 10 shots it will stop shooting, i can hear the trigger still clicking but the bolt doesn't come back far enough, so i pull it back the rest of the way, (about 1 cm) and keep going,
why does it do this, everything is lubed up good.

fastdrum6
01-16-2008, 12:35 PM
It might be the striker bolt. I was recently fixing my friends rodeo and when trying to put the gun back together I was having trouble getting the bolt to go in. So u might want to check that.

Kenny_McCormic
01-18-2008, 05:51 PM
Your hopper isnt feeding fast enough and a half chambered ball is stopping the bolt.

It might be the striker bolt. I was recently fixing my friends rodeo and when trying to put the gun back together I was having trouble getting the bolt to go in. So u might want to check that.

You have to pull the trigger to get the internals to slide in.

frank2591
02-05-2008, 11:09 PM
as said above its not feeding fast enough and the ball is being half chambered...Have you tried cleaning your gun makin sure no residue of paintballs is their because that can keep the bolt from going back...my friend had the same problem all he dad was clean it out and it turned out a chopped paintball wasnt allowing the bolt to always go back.


The difference between men and boys, is the price of their toys.

kramernator
02-06-2008, 09:34 AM
actually i think you are right. i cleaned it out and it has been working alright, thanks!

btw disturbed is awesome!!!

Paintballer5000
02-06-2008, 11:29 AM
Do you have the right bolt if not you might have yo get a new one.