PDA

View Full Version : aggressor xt


PAINTBALLWIZ
01-01-2008, 04:51 PM
my cousins xt will not recock.first shot is great but will not kick and recock please help.

Hossy
01-01-2008, 04:55 PM
Is there CO2 in the tank?
Id suggest checking the valve as well.
Also oil all of your Orings and check for anything that may be in the way of the bolt/striker

Kenny_McCormic
01-01-2008, 04:55 PM
Does it fart or anything? Clean it, lube it and replace the hammer oring.

Ace24
01-01-2008, 05:03 PM
Is your tank screwed in all the way? Is your frame on tight? Is the ram in backwards?

vwjimmy
01-01-2008, 06:03 PM
Replace the striker o ring. It is the o ring on the heavy piece in the lower tube. Then, clean all the internals and lube all the o rings.
That should do it!

PAINTBALLWIZ
01-03-2008, 06:22 PM
iv'e done all that but still will not.the first shot has great distance and velocity.but there after it's like it's not recharging.iv'e tried it with co2 and nitrogen.

vwjimmy
01-03-2008, 06:37 PM
Well, Spyders recock by 'blowback'. Some of that charge that shots the first paintball so well is directed into the lower tube to force the bolt back into the 'cocked' position. Most older Spyders I 'tech' have bad striker o rings that let the charge leak past rather than pushing the striker. What kind of o ring did you use on the striker? Did you clean the lower tube? Did you take the frt of the lower tube apart and clean the valve area? If so, it is probably time to take the valve out and re oring it as well.