PDA

View Full Version : Auto-Sonix?


venom3carnage
12-09-2007, 11:33 AM
so i first have a sonix and then i got a VS3. i havent touch my sonix in about 3 months and decided to give it to my son for a x-mas present because he is starting to get into it. Well hooked everything up and decided to test everything before i gave it to him(dont want to give away a broked peice of) anyway when i hooked up everything and shot i could just hold the trigger and it sounded like it was in full auto. since the marker is semi only i was totally lost on what could be wrong. at first i thought the air was low but i have a full tank. any sugggestions on whats wrong?

DFSniper
12-09-2007, 11:48 AM
sounds like the sear isnt catching right. take the frame off and check to see if the sear edge is rounded or if there is a chip on the bottom of the striker.

venom3carnage
12-09-2007, 03:05 PM
well i dont know what a sear is but i took the handle off and the thing the derlin bolt goes into looks ok and the thing the catchs that thing looks ok too.

DFSniper
12-09-2007, 03:14 PM
yeah, the sear is the part that sticks out of the trigger frame to catch the striker is the sear. have you ever taken the gun completely apart? if you put the valve in backwards (small hole facing out the front) that may have caused it too.

Kenny_McCormic
12-09-2007, 03:47 PM
Make sure the frame is on tight.

venom3carnage
12-10-2007, 04:11 AM
no everything is on right, no chip or dings and the striker is on right. i will tighten the frame when i get home and test it again. that may be the problem.

venom3carnage
12-13-2007, 06:25 AM
sorry it took so long to respond but i tightened the frame and oiled the striker and cleaned it and nothing it still shoots like a auto. if no one has anymore suggestions im sending this to kingman.

Kenny_McCormic
12-13-2007, 12:22 PM
Valve in backwards? Will it recock if you remove the barrel and hold your hand over the end of the gun? Check the valve pin for scratches if its scratched up real bad then you have a bad valve spring and need to replace it.

Sonix_Nub3
12-28-2007, 01:31 PM
my sonix is doing the same thing i also need help..

jamo23
10-14-2009, 02:17 PM
check the trigger switch