PDA

View Full Version : New stuff !!!


mv540
10-22-2007, 06:18 PM
Well, Yesterday I had practice, a normal practice, but gat some sweet deals on some stuff, and other ones free!! :)

so, this field sponsors my team, and some of this sponsorship is some disscount on their products.

So first some angels elbowpads, got them for like 20 bucks, they look a lil funny, and thats beacuse I just wash'em, cause yesterday was a really rainy day, so the field was a lil bit muddy.

http://i43.photobucket.com/albums/e379/percast/PICT0599.jpg



Some paint, actually a gat this paint for free, just to try'em out, some empire paint, some cammo paint (i totally forget the name right now), and some pro spyder paint. Spyder paint sucked, the empire paint was aight, and the cammo, well I havent it tested yet.

http://i43.photobucket.com/albums/e379/percast/PICT0603.jpg

this is the empire paint, the green one, and just I think it was cool, the skull print on the piant. :)

http://i43.photobucket.com/albums/e379/percast/PICT0611.jpg



Also a new empire reloader b, for about 65 bucks, sweet deal. (brand new)

http://i43.photobucket.com/albums/e379/percast/PICT0585.jpg

oh also I broke my fasta lid, so I made a ghetto speed feed, I made it out of a pringle lid, lol.....it looks ugly...

http://i43.photobucket.com/albums/e379/percast/PICT0597.jpg




Well and finally, a guy at the field, he was talking to me, and I was like waasup and stuff, and at the end of the day he give me this: a timmy!, for free!, I was like....oh, thx bro...

http://i43.photobucket.com/albums/e379/percast/PICT0592.jpg



http://i43.photobucket.com/albums/e379/percast/PICT0590.jpg


So this is the main reason I post this, I need help!!!, i dont know what to do with it, I dont know what year it is, I think is a very old gun, but i think it has a lil potential..heh.. ( The only up I found in it, was the dye ultralite barrel)

Also, I tested it, and time to time, the pressure droped down and my paintballs just get like a meter far...and I dont know whats wrong, like 50 shots normal, and then it goes down, but then its just perfect again, so.......help:)

oldironmudder
10-22-2007, 06:21 PM
dude, its like freaking x-mas for you!!!

The Pumper
10-22-2007, 06:22 PM
Umm..i believe thats a system x NME

SupaSnipa
10-22-2007, 06:36 PM
Umm..i believe thats a system x NME
a big :yeahthat:
It is a System X NME LE I believe. It uses timmy parts so you might beable to use a timmy trigger guard. What else does it need, you can get hybrid or sticky grips for it.

timmyshoota
10-22-2007, 06:41 PM
Timmy trigger guards won't work on an NME I believe. Sounds like you are having regulator issues if its working fine and then dropping off.

mv540
10-22-2007, 06:50 PM
Timmy trigger guards won't work on an NME I believe. Sounds like you are having regulator issues if its working fine and then dropping off.


oh...yeah, I think its that, cause when I chrono it, it will only work "good" at 365 fps...so :( ...maybe its that, how can I fix it?:o

timmyshoota
10-22-2007, 07:05 PM
My suggestion is to get an Intimidator Empire front block with an LPR and buy a new regulator. That'll eliminate the external LPR hose, and you'll get better regulators.

big_daddy_d
10-22-2007, 07:07 PM
cool that you got it for free.

mv540
10-22-2007, 07:12 PM
My suggestion is to get an Intimidator Empire front block with an LPR and buy a new regulator. That'll eliminate the external LPR hose, and you'll get better regulators.


ok, thx 4 the help...

Oscum Guy
10-22-2007, 07:37 PM
omfg you got an nme for free! jeezus! just wow.. wow omg.

mv540
10-22-2007, 07:43 PM
yeah Oscum....cant believe it myself...:p