View Full Version : help with my e99 avant

08-13-2007, 10:33 AM
Hi there, i recently bought a used e99 avant from a friend and im having a little problem with it. Ive used the gun a few times already but yesterday when i went to go play around with soem friends, i fired ther gun and it seemed to get stuck on full auto, firing without the trigger even being pushed. I turned the gun off and it still didnt stop. I had to unplug the co2 before it would stop. After that i tryed plugging in a new co2 canister because i thought it might have been that, but now the gun wouldnt cock. I pull back the lever and it doesnt stick, it just slides right back into place. I have no idea what is wrong with it. I have lubed everything and taken apart the gun as shown in the videos on the website but they didnt help. Please if you have any idea what is wrong help me out. Thanks ;)

08-13-2007, 10:35 AM
You out of Co2? Get the tanks refilled.

check all your o-rings.

08-13-2007, 10:38 AM
Full tank like speed said & make sure the striker oring is still in good shape.

08-13-2007, 12:39 PM
the sear is stuck down

08-13-2007, 10:55 PM
Yea the o-rings and co2 are all fine. The sear i have no clue what is. Any help with that?

08-14-2007, 05:50 AM
When you have the marker internal out of the rear look in the bottom tube & you will see a small piece of metal sticking up, thats the sear.

08-14-2007, 06:07 AM
Yeah, there has to be a problem with your striker or sear. Inspect both of those. There has to be a spring underneath the sear on the top of the trigger frame, if there isn't that could be your problem.

Only other thought is, there could be something stuck behind the striker preventing it from going back far enough to lock into the sear.

If you take the trigger frame off the body of the gun, the sear is the little metal "L" shaped part that sticks out of the top of the trigger.

08-19-2007, 08:04 PM
a lot of times the sear will stick down if the top grip panel screw is too tight.