PDA

View Full Version : Electra wont cock (not striker buffer)


Paintball noob
03-28-2007, 01:30 PM
:mad: :mad: Before this thread i asked the same question and people were saying it was because im missing my striker buffer but im not.:mad: :mad:
My question is why wont my Spyder Electra cock back? When i pull it back it doesn't lock in place it will just slide back forward.:mad: :mad:
Please help me i really want to play with my friends again and "Supply Depot" the store i used to use moved and now all i got is "****s" and they dont know ****.
I dont know if this means anything but maybe it does.......Sometimes when i try to cock it back then pull the top half of the trigger (it's a rocking trigger frame) it will make a loud click noise as if it would if it was working , normally it only does that once but one time it went on for about 8 clicks.

Kenny_McCormic
03-28-2007, 01:58 PM
it sounds like either your striker is ****ed up (unlikly because its hardened steel) or yout trigger frame is ****ed up the sear is probably wore out/stuck

BrianT
03-28-2007, 04:16 PM
take the gun apart agian and make sure everything is in the correct place. sometimes something could have gotten reveresed by mistake.

kidonfire
03-28-2007, 05:26 PM
Make sure the sear is not rounded. Have you shimmed the frame(put a nickle or dime behind the noid)? If you shimmed the noid too much, then the hammer might not catch.

Paintball noob
03-30-2007, 04:43 PM
Kidonfire could u inform me about the sear?hammer? and all that ill check later when i have more time to look at the manuel.
All i know is what ever is suppose to fall into place to hold the cocker thing in place , the thing that sticks up when u take off the brownish thing (maybe its brown from rust) that goes into the bottom of the white cocker thing........Do u know that little kinda small rectangle thing that sticks up? Well anyway it seemed kinda flimsy......Didn't seem like it would be strong enough to hold anything in place.....Think that's what's going on?

kidonfire
03-30-2007, 04:54 PM
The hammer is also called the striker. when you fire the gun it hits the valve pin which lets air in propelling the paintball. When you take the trigger frame off, the sear is the part that sticks up out of the frame. It catches the hammer and keeps it from firing until you pull the trigger.

Here's a great explanation that OtterSC has on his site.

http://www.ottersccustoms.com/works.html

Paintball noob
04-07-2007, 11:45 AM
I think my "sear" is broken. Maybe when i put it all back in i bent it or dismantled or loosend it. It seemed kinda weak and unsturdy when i touched it , didn't seem like it would be strong enough to hold that spring back. Ill fidle with it and if that doesn't work ill go to a store.
Thankyou for your help and ill make a post when its all working and im back playing again.
:) :) :)

Kenny_McCormic
04-07-2007, 12:01 PM
you could always pick up a used mech frame cheap until the eframe is fixed. is the e frame under warranty? call kingman

kidonfire
04-07-2007, 01:08 PM
I think my "sear" is broken. Maybe when i put it all back in i bent it or dismantled or loosend it. It seemed kinda weak and unsturdy when i touched it , didn't seem like it would be strong enough to hold that spring back. Ill fidle with it and if that doesn't work ill go to a store.
Thankyou for your help and ill make a post when its all working and im back playing again.
:) :) :)

check the upper edge of the sear to make sure its not rounded or chipped.

Paintball noob
04-17-2007, 05:31 AM
me and my cousin took the whole damn thing apart and pulled what we think is the sear up and it seemed sturdy but nothing different happed , im going to take it to a shop this week i think thanx for all your help anyway , at least no i know alot more about the parts of the gun and stuff.

hudabom246
07-12-2007, 04:56 PM
on some guns, if your velocity is all the way up it wont cock back. try turning your velocity down.

Command2A
08-01-2007, 07:54 PM
I have an Electra ACS hanging around (don't use it anymore) if you need any parts PM me. I'll send them to ya for the cost of postage only.

oldironmudder
08-02-2007, 03:37 AM
Take apart the lower tube, striker, spring, buffer, etc.... Leave only the striker, spring, spring guide & back the adjuster all the way out & try it. If it works put the buffer & metal disk back in & just start the threads on the adjuster.

It sounds like you spring is going solid before it ever should. Just got to remove some material til it works.